Go Back   United Bimmer Community - BMW Forum > UnitedBimmer- Model Categories > M3
Register FAQ Members List Calendar Advertise With Us Mark Forums Read

M3 General discussion and technical help all year M3 cars.

Reply
 
Thread Tools
Old 05-22-2010, 07:12 PM   #16
MyXc351

Name: MyXc351
Title: United Newb
Status: Offline
Join Date: Dec 2009
Location: Brisbane
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 1989 525I
hey guys, i had similar problem on my E34 89 model 525i. Not sure just what part i fixed to get rid of the vibration as i had to fix several things at the same time! started with replacing one of my engine mounts as it was broken, replaced the 2 rear pitman arm links and also took tailshaft off and filled the rubber flex mount? (between gearbox and tailshaft) with Sikaflex.
Car drives good now
  Reply With Quote
Old 03-28-2011, 02:51 PM   #17
glfe50

Name: glfe50
Title: United Newb
Status: Offline
Join Date: Feb 2010
Location: usa
User not setup in Rate My Car.
Click here to set it up.
Your Ride: BMW 528 1997
I am having vibration at 45 mph. Changed both rear ball joints, control arms, sway bar links, brakes, rotors and tires and still have the vibrations.
  Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Airplane Flight Question komodo United Off Topic  **FOR MEMBERS ONLY** 105 07-27-2007 09:35 AM


All times are GMT -5. The time now is 12:34 AM.

A vBSkinworks Design

 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright © 2005-2013 UnitedBimmer.com