Go Back   United Bimmer Community - BMW Forum > UnitedBimmer- Model Categories > 5-Series
Register FAQ Members List Calendar Advertise With Us Mark Forums Read

5-Series General discussion and technical help for 5-series BMWs.

Reply
 
Thread Tools
Old 02-27-2012, 02:23 AM   #1
radarfxst

Name: radarfxst
Title: United Newb
Status: Offline
Join Date: Sep 2011
Location: Ramstein, Germany
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 1995 525i
Verify the "Check Engine" lamp?

I bought a used German-spec 1994 525i, and it turns out it wasn't in as good shape as I was led to believe. I've done some work to it and it runs good now, but I noticed that the "check engine" lamp never comes on - not even when first starting it up, as with most of my previous vehicles.

Based on the work I've had to do so far, it wouldn't surprise me if the previous German owner disconnected the check engine lamp. So I have two questions:

1. SHOULD the check engine lamp come on when the car is first started up?

2. If not, what is the easiest way to verify that the lamp works like it's supposed to? I'm hoping there is something in the engine compartment that I can disconnect (without damaging anything, of course) that should turn the light on. If the light comes on, I'm good. If it doesn't come on, troubleshooting time.

Thanks,

Tom
  Reply With Quote
Old 02-28-2012, 12:10 AM   #2
DEATH2000
 
DEATH2000's Avatar

Name: DEATH2000
Title: Moderator
Status: Offline
Join Date: May 2005
Location: Calgary, Alberta
Rate My Car: 111 / 340
Your Ride: 1998 E36 328i sedan
Yes it should come on for a few seconds upon start up. The bulb could have been disconnected or removed. Te only way to tell is to remove the gauge cluster.
__________________


VIEW MY E36 BLOG HERE

New to United Bimmer? Check out our Introductions and Greetings Section and introduce yourself today!

E36 Bentley Manual PDF download avilable HERE
  Reply With Quote
Old 02-28-2012, 12:59 AM   #3
radarfxst

Name: radarfxst
Title: United Newb
Status: Offline
Join Date: Sep 2011
Location: Ramstein, Germany
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 1995 525i
Thanks for the reply. Before I pull the cluster, is there something fairly simple I can disconnect in the engine compartment that SHOULD turn the "check engine" light on?
  Reply With Quote
Old 02-28-2012, 07:33 AM   #4
DEATH2000
 
DEATH2000's Avatar

Name: DEATH2000
Title: Moderator
Status: Offline
Join Date: May 2005
Location: Calgary, Alberta
Rate My Car: 111 / 340
Your Ride: 1998 E36 328i sedan
Try the MAF sensor. If that doesn't work an O2 sensor will. But their under the car.
__________________


VIEW MY E36 BLOG HERE

New to United Bimmer? Check out our Introductions and Greetings Section and introduce yourself today!

E36 Bentley Manual PDF download avilable HERE
  Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:43 AM.

A vBSkinworks Design

 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright © 2005-2013 UnitedBimmer.com