Go Back   United Bimmer Community - BMW Forum > UnitedBimmer- Model Categories > E36
FAQ Members List Calendar Advertise With Us Mark Forums Read

E36 General discussion and technical help for (E36) 1992-1999 3 series cars. 318, 323, 325, 328.

Reply
 
Thread Tools
Old 01-25-2012, 02:12 AM   #1
zvigenizvigeni

Name: zvigenizvigeni
Title: United Newb
Status: Offline
Join Date: Jan 2012
Location: los angeles
User not setup in Rate My Car.
Click here to set it up.
Your Ride: BMW 325IS E36
chokes only after 80mph

hello guys im having a problem on my bmw e36 325is 94(automatic).i bought this car about 2 months ago and i just noticed a problem that when i drive on high way car chokes .after 80mph when i push the gas car chokes and accelerates very slow (in 5th gear).if its an uphill the problem is getting even worse .also techomiter is kinda going back and forth for a little bit.the problem occurs only after 80 mph ,it feels like im running out of gas or something like that .also i feel like car wants to go but something forces it to not to.i took it to a body shop had it checked by obd1 and they replaced 2 ignition coils and all 6 spark plugs .i putted a new air filter on it but car is having a same problem again .can anyone please help me what to do pls.i think its a fuel filter or the pump .help plsssssssssssss
  Reply With Quote
Old 01-25-2012, 01:13 PM   #2
DEATH2000
 
DEATH2000's Avatar

Name: DEATH2000
Title: Moderator
Status: Offline
Join Date: May 2005
Location: Calgary, Alberta
Rate My Car: 111 / 340
Your Ride: 1998 E36 328i sedan
Welcome to United Bimmer.

Let's start with the front. How is the air filter? Is the MAF sensor dirty/clogged? How is te throttle body? Is it dirty? Does it open and close easily?
__________________


VIEW MY E36 BLOG HERE

New to United Bimmer? Check out our Introductions and Greetings Section and introduce yourself today!

E36 Bentley Manual PDF download avilable HERE
  Reply With Quote
Old 01-25-2012, 02:39 PM   #3
zvigenizvigeni

Name: zvigenizvigeni
Title: United Newb
Status: Offline
Join Date: Jan 2012
Location: los angeles
User not setup in Rate My Car.
Click here to set it up.
Your Ride: BMW 325IS E36
thanks for respond

air filter is a brand new.i have never checked maf sensors.throtile body is good.it openes and closes with no problem .the problem happens only after 80mph .it wont go any faster if i wont floor the gas pedal(that way it downshifts gains some speed and then goes fine).Also no check engine light is on. No codes. My mechanic checked it with the computer and sad that car has no problems but that is not true. After 80 car would start acting wierd like running out of gas and if i press gas pedal more the problem is getting even worse and if i floor it the no problem it starts to downshift and gains up to 90 mph with np.

Last edited by zvigenizvigeni; 01-25-2012 at 04:07 PM..
  Reply With Quote
Old 01-26-2012, 10:23 AM   #4
Big Evil
 
Big Evil's Avatar

Name: Big Evil
Title: Moderator
Status: Offline
Join Date: Nov 2008
Location: Tempe, Az
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 1994 BMW 525i, 1987 325is, 1986 325
Replace the fuel filter (its easy and cheap enough). If that doesn't do it, get the fuel pressure AND volume checked.
__________________
Big Evil, The BMW driving monster of the American Southwest (Currently on BMW #5)
  Reply With Quote
Old 01-31-2012, 01:27 AM   #5
zvigenizvigeni

Name: zvigenizvigeni
Title: United Newb
Status: Offline
Join Date: Jan 2012
Location: los angeles
User not setup in Rate My Car.
Click here to set it up.
Your Ride: BMW 325IS E36
Quote:
Originally Posted by Big Evil View Post
Replace the fuel filter (its easy and cheap enough). If that doesn't do it, get the fuel pressure AND volume checked.
i replaced the fuel filter and i saw little improvement. today also i tried to accelerate fast and car started choking (same thing what it used to do above 80mph).and it would not go more faster.then i relised the gas pedal about 80% and it started gaining speed.mileage is about 160000.my mechanic can not find the problem .can anyone halp me plz.
  Reply With Quote
Old 01-31-2012, 04:44 AM   #6
DEATH2000
 
DEATH2000's Avatar

Name: DEATH2000
Title: Moderator
Status: Offline
Join Date: May 2005
Location: Calgary, Alberta
Rate My Car: 111 / 340
Your Ride: 1998 E36 328i sedan
Fuel pump okay? What about injectors? Does it only do it at WOT?
__________________


VIEW MY E36 BLOG HERE

New to United Bimmer? Check out our Introductions and Greetings Section and introduce yourself today!

E36 Bentley Manual PDF download avilable HERE
  Reply With Quote
Old 02-01-2012, 10:18 AM   #7
Big Evil
 
Big Evil's Avatar

Name: Big Evil
Title: Moderator
Status: Offline
Join Date: Nov 2008
Location: Tempe, Az
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 1994 BMW 525i, 1987 325is, 1986 325
So did you get the fuel pressure AND volume tested?
__________________
Big Evil, The BMW driving monster of the American Southwest (Currently on BMW #5)
  Reply With Quote
Old 02-08-2012, 11:14 PM   #8
zvigenizvigeni

Name: zvigenizvigeni
Title: United Newb
Status: Offline
Join Date: Jan 2012
Location: los angeles
User not setup in Rate My Car.
Click here to set it up.
Your Ride: BMW 325IS E36
thank you for responding

Quote:
Originally Posted by DEATH2000 View Post
Fuel pump okay? What about injectors? Does it only do it at WOT?
hi,i pologize for not responding for so long.still got the same problem beside a very high consumption of fuel.ussually car chekes from 3 to 3.5/4 rpm and wont gain the speed no matter how hard i push the gas .we checked the fuel pressure and it was good.idk what to do.i took a look on injectors but not a problem .
  Reply With Quote
Old 02-08-2012, 11:15 PM   #9
zvigenizvigeni

Name: zvigenizvigeni
Title: United Newb
Status: Offline
Join Date: Jan 2012
Location: los angeles
User not setup in Rate My Car.
Click here to set it up.
Your Ride: BMW 325IS E36
idk about the pump can it also be a problem ?why did the consumption increased? 11mpg
  Reply With Quote
Old 02-09-2012, 02:31 AM   #10
DEATH2000
 
DEATH2000's Avatar

Name: DEATH2000
Title: Moderator
Status: Offline
Join Date: May 2005
Location: Calgary, Alberta
Rate My Car: 111 / 340
Your Ride: 1998 E36 328i sedan
Have you tried the Throttle Position Sensor (TPS) or Crankshaft Position Sensor (CPS)? A bad sensor could be causing the issue.
__________________


VIEW MY E36 BLOG HERE

New to United Bimmer? Check out our Introductions and Greetings Section and introduce yourself today!

E36 Bentley Manual PDF download avilable HERE
  Reply With Quote
Old 02-09-2012, 10:28 PM   #11
zvigenizvigeni

Name: zvigenizvigeni
Title: United Newb
Status: Offline
Join Date: Jan 2012
Location: los angeles
User not setup in Rate My Car.
Click here to set it up.
Your Ride: BMW 325IS E36
Idk that much about the cars man. Im thinking to take it to another mechnlc but i dont wanna do it because they lie a lot and steal your money. I have not see any honest mechanics in la. Any advices pla

Last edited by zvigenizvigeni; 02-09-2012 at 10:29 PM..
  Reply With Quote
Old 02-10-2012, 12:36 AM   #12
DEATH2000
 
DEATH2000's Avatar

Name: DEATH2000
Title: Moderator
Status: Offline
Join Date: May 2005
Location: Calgary, Alberta
Rate My Car: 111 / 340
Your Ride: 1998 E36 328i sedan
In my signature is the link to the Bentley Service Manual. It is I e of the most comprehensive guides for the E36 available. Take a read through it and it will help explain more about the TPS,CPS and other mechanical areas. This way you will learn a fair bit about your vehicle and if you need to take it to a mechanic then you will be more informed and less likely to get fleeced.
__________________


VIEW MY E36 BLOG HERE

New to United Bimmer? Check out our Introductions and Greetings Section and introduce yourself today!

E36 Bentley Manual PDF download avilable HERE
  Reply With Quote
Old 02-13-2012, 09:52 PM   #13
zvigenizvigeni

Name: zvigenizvigeni
Title: United Newb
Status: Offline
Join Date: Jan 2012
Location: los angeles
User not setup in Rate My Car.
Click here to set it up.
Your Ride: BMW 325IS E36
hey guys .finally got my car fixed .problem came up to be a cranckshaft position sensor .i found a good mechanic in hollywood(which is very hard) and he fixed my car in like 1 hr . thank you everyone for your help.hope this post will help others
  Reply With Quote
Old 02-13-2012, 09:53 PM   #14
zvigenizvigeni

Name: zvigenizvigeni
Title: United Newb
Status: Offline
Join Date: Jan 2012
Location: los angeles
User not setup in Rate My Car.
Click here to set it up.
Your Ride: BMW 325IS E36
Quote:
Originally Posted by DEATH2000 View Post
Have you tried the Throttle Position Sensor (TPS) or Crankshaft Position Sensor (CPS)? A bad sensor could be causing the issue.
you were right cranckshaft position sensor
  Reply With Quote
Old 02-14-2012, 02:00 AM   #15
DEATH2000
 
DEATH2000's Avatar

Name: DEATH2000
Title: Moderator
Status: Offline
Join Date: May 2005
Location: Calgary, Alberta
Rate My Car: 111 / 340
Your Ride: 1998 E36 328i sedan
Quote:
Originally Posted by zvigenizvigeni View Post
hey guys .finally got my car fixed .problem came up to be a cranckshaft position sensor .i found a good mechanic in hollywood(which is very hard) and he fixed my car in like 1 hr . thank you everyone for your help.hope this post will help others
Excellent. Glad to hear it worked out okay for you!
__________________


VIEW MY E36 BLOG HERE

New to United Bimmer? Check out our Introductions and Greetings Section and introduce yourself today!

E36 Bentley Manual PDF download avilable HERE
  Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:04 AM.

A vBSkinworks Design

 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright © 2005-2013 UnitedBimmer.com