Go Back   United Bimmer Community - BMW Forum > UnitedBimmer- Model Categories > M3
FAQ Members List Calendar Advertise With Us Mark Forums Read

M3 General discussion and technical help all year M3 cars.

Reply
 
Thread Tools
Old 05-19-2010, 11:56 PM   #1
kazamali

Name: kazamali
Title: United Newb
Status: Offline
Join Date: Apr 2009
Location: San Jose, CA
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 99 M3
Calling all fuel trim experts!!

Hey guys,

I've been chasing a fuel trim issue for quite some time and need some expert help. I'm including a lot of data, so hopefully it will accelerate and narrow the areas of investigation.

The facts:

1999 E36 M3, 96k miles, Supercharged via AA Twin-screw (9lb psi), stock exhaust

-O2, MAF, Fuel filter and regulator replaced 1 year ago
-Spark plugs and fuel injectors replaced a few weeks ago
-Car throws 1188/1189 codes (fuel trim) consistently after a few "trips"
-Plugging in an OBDII data logger shows positive fuel trim(10% - %20+) all the way from idle, hard acceleration and cruising speed.
-Car has had supercharger for 4 years now and initially had trim issues when first installed(vacuum leak), but has run fine since for 2 solid years without issue
-Car is showing larger positive trim at cruising speed, not at idle (the latter usually indicates a vacuum leak as vacuum is larger at idle)
-Car shows no physical signs of issues (i.e. no limping, hesitation on acceleration, nor rough idle)

I just need some direction on where to go next since these codes are preventing a successful smog check (resetting the ECU doesn't work because the "monitors" in the ECU will reset). This is really looking like a vacuum leak issue (which, at this point, is going to require a smoke test because I've been over every hose and seal a million times), but I wanted to make sure if this is possibly pointing to a fuel pump failing or another MAF issue.

I'm hyperlinking graphs of a 5 mile trip that show values of short term fuel trim for both banks at different RPM/Throttle Position plot points AND MAF volume reports at the same plot points. (note that idle is at around 800 RPM and 15% Throttle angle and cruising speed is 3200 RPM and %30 Throttle Angle) On top of that, I also have a link that shows the same trip, but in a line graph showing the same values in a different way. Note that I've reset the adaptations to start off fresh and that's why the Long Term Fuel Trims are small (they WILL grow to %12 percent if I drive long enough).

I need someone to take a look and see if there's a definite smoking gun here so I don't blindly go and check a bunch of other things unnecessarily.

I'm trying to be as thorough here for you guys as much as possible, but let me know if I've missed anything.


Table of STFT and MAF readings

Graph of data (for the same trip)

Thanks!

Kazam

Last edited by kazamali; 05-19-2010 at 11:59 PM..
  Reply With Quote
Old 05-20-2010, 09:54 AM   #2
Big Evil
 
Big Evil's Avatar

Name: Big Evil
Title: Moderator
Status: Offline
Join Date: Nov 2008
Location: Tempe, Az
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 1994 BMW 525i, 1987 325is, 1986 325
Smoke check it, start with the vac system first, if it passes. Move on to fuel pressures, could be a fuel pump going away, could be a fuel regulator going away, could just need a new fuel filter. CA plays with their damn fuel blends so much it kills rubber components constantly (had a HUGE issue with it here in PHX a few years back). Fuel quality can prematurely clog up a filter if its bad and it only takes one tanker to contaminate hundreds of vehicle fuel systems.

Best bet, start with the basics (and least expensive), then work your way up systematically.
__________________
Big Evil, The BMW driving monster of the American Southwest (Currently on BMW #5)
  Reply With Quote
Old 08-17-2010, 06:43 PM   #3
kazamali

Name: kazamali
Title: United Newb
Status: Offline
Join Date: Apr 2009
Location: San Jose, CA
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 99 M3
Solved!

So, sorry for the laaate update on this, but between vacations and mail-ordering supplies, it's taken a while. All in all, the resolution was:

**Active Autowerke's MAF Calibrator box**

Yep, that was it. The longer story:

I took everyone's feedback and had a smoke test and fuel pressure test done. I did find very minute issues with my fuel pump (it wasn't holding pressure as it should after the engine was shut off), but operating pressure was fine, nonetheless. Smoke test came out just fine too. (I had a guy in San Jose do both tests for less than a C-note). He smoked the SC and my valve cover. No issues.

So I took this data, plus the OBD log/fuel trim data and called Active Autowerke(Florida) where I bought my SC. Turns out the calibrator box they sent me to replace my failed one 1.5 years ago wasn't doing it's job properly. It was essentially underrreporting airflow and subsequently causing the O2's to up (waaaay up) the mix in response to a lean one. Since I wasn't due for smog at that time, I ignored the randome MIL's.

The SC kit I have was orginally using a 5-series MAF to accomodate the larger air flow and a "calibrator" box had to be used between it and the ECU to make it all work(voltage outputs are different). Active's subsequent, UPDATED, replacement for my failed one was apparently bogus, but they had a solution THIS TIME to use a Porsche MAF without the calibrator. Fine by me, because that would be one less part to fail in the future. I just needed to get my ECU reflashed to work with the new MAF's outputs. Long story short, I'm on the Porsche MAF, updated ECU, LTFT's came down to 0.8% and 1.6% and I passed CA smog today, legally. Woot!

So in short, here's what I learned: Before doing ANY type of crazy modifications to your engine/emissions, buy an OBDII logger and take baseline measurements on EVERYTHING. Take a repeatable short trip so that you can compare numbers before and after your change (that's how I knew, after the fact unfortunately, the old calibrator was misreporting the airflow). The only reason why I even got thru to Active so fast was that I was able to (along with smoke/fuel test results) clearly explain what was going on. Most folks tell them "My Engine light is on"(help with this is waay limited). They immediately knew what it was and BAM, I had a fix within a few days. My only gripe is that they didn't proactively tell me this after they sent a bogus calibrator(but, had I used an OBDII logger, I would have caught this on my own a long time ago). Whatever. For all you tweakers out there, just invest $150 in some scanning equipment and you'll be golden. Trust me.

I hope to share the 300% of great things I learned with the rest of you in your future posts.

Thanks for ALL of your help.....it *really* did accelerate the process (even tho it took ME months...haha).

Sorry for the long post, but this was a big win for me.

-Kazam
  Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
E36 fuel pump: diagnosis & replacement Dudesky BMW OEM Parts Department DIY's & FAQ's 13 11-25-2011 10:32 PM
No fuel at the rail? need help please phantomsys E46 2 06-10-2010 07:10 PM
Help With Fuel pump and no power!!! POS_BMW E36 7 11-27-2009 10:14 PM
Fuel trim Issue??? IBIMMER E12, E28, E34, E39, E60 12 12-26-2007 08:28 AM
History of gasoline! what is gas? and why it is NOT gasoline we pay for at the pump? delmarco United Off Topic  **FOR MEMBERS ONLY** 4 11-28-2005 02:29 PM


All times are GMT -5. The time now is 08:19 AM.

A vBSkinworks Design

 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright © 2005-2013 UnitedBimmer.com