Go Back   United Bimmer Community - BMW Forum > UnitedBimmer- Model Categories > 5-Series > E12, E28, E34, E39, E60
FAQ Members List Calendar Advertise With Us Mark Forums Read

E12, E28, E34, E39, E60 General discussion and technical help for all year 5 series cars.

Reply
 
Thread Tools
Old 08-03-2010, 08:39 PM   #1
mdrexusa

Name: mdrexusa
Title: United Newb
Status: Offline
Join Date: Jul 2010
Location: Tennessee
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 2000 528i
Angry P1421 & P1423 Codes

I have a 2000 528i w/ 118000 Miles. I have replaced the air-pump, air-pump valve & the relay. The pump runs but the ck engine light comes back on after 4 to 6 starts. I have a code reader and it always shows P1421 & P1423 as the codes. ANY ideas??? I'm about to pull the rst of my hair out. Any help will be appreciated.:
  Reply With Quote
Old 08-10-2010, 02:17 PM   #2
mdrexusa

Name: mdrexusa
Title: United Newb
Status: Offline
Join Date: Jul 2010
Location: Tennessee
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 2000 528i
Still no suggestions. I could really use some ideas here. Thanks
  Reply With Quote
Old 08-16-2010, 09:41 AM   #3
Big Evil
 
Big Evil's Avatar

Name: Big Evil
Title: Moderator
Status: Offline
Join Date: Nov 2008
Location: Tempe, Az
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 1994 BMW 525i, 1987 325is, 1986 325
Both secondary air system codes (bank 1 and 2), are there any splits or leaks in the hoses? You may want to smoke check the system.
__________________
Big Evil, The BMW driving monster of the American Southwest (Currently on BMW #5)
  Reply With Quote
Old 08-16-2010, 04:56 PM   #4
mdrexusa

Name: mdrexusa
Title: United Newb
Status: Offline
Join Date: Jul 2010
Location: Tennessee
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 2000 528i
Quote:
Originally Posted by Big Evil View Post
Both secondary air system codes (bank 1 and 2), are there any splits or leaks in the hoses? You may want to smoke check the system.
The main hose from the valve to the pump was replaced because the other one was cracked. I even replaced the vacuum line from the vacuum system to the valve. I will try the smoke test though and thanks for the reply. mdrexusa
  Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine codes - anybody speak "dealer?" volvodefector79 E36 4 05-25-2010 08:11 PM
Australia error codes fenlux E36 1 03-31-2009 09:58 AM
OK - getting codes, CHECK ENGINE light works, but it's not on! volvodefector79 E36 1 11-13-2007 05:46 PM
possible O2 sensor issue. what do you think of these fault codes? bimmerZ5 BMW OEM Parts Department DIY's & FAQ's 5 02-02-2007 12:19 AM
Trouble Codes Spieluhr E36 5 05-29-2005 06:29 PM


All times are GMT -5. The time now is 04:14 AM.

A vBSkinworks Design

 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright © 2005-2013 UnitedBimmer.com