Go Back   United Bimmer Community - BMW Forum > UnitedBimmer- Model Categories > 7 Series (E23, E32, E38, E65, E66)
Register FAQ Members List Calendar Advertise With Us Mark Forums Read

7 Series (E23, E32, E38, E65, E66) General discussion and technical help for all year 7 series cars.

Reply
 
Thread Tools
Old 06-19-2010, 08:20 AM   #1
randall

Name: randall
Title: United Newb
Status: Offline
Join Date: Jun 2010
Location: cape town
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 1995
oil light comes on after starting

The oil light of my 1995 740i comes on a min or 2 after starting it starting out very dim and gradually brightens. There's no warning message on my display. Is this oil pressure switch variable or just a on-off switch? Any advise PLEASE.
  Reply With Quote
Old 09-06-2010, 11:30 AM   #2
sandersnsandy
 
sandersnsandy's Avatar

Name: sandersnsandy
Title: United Newb
Status: Offline
Join Date: Mar 2008
Location: Boring Or.
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 1997 740i
My 97 recently did the same thing. Thinking my oil filter was dirty and the oil was triggering a bypass sensor , I changed both and havent had it happen since.
  Reply With Quote
Old 07-08-2011, 01:15 AM   #3
balwit

Name: balwit
Title: United Newb
Status: Offline
Join Date: Jul 2011
Location: McMinnville, OR
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 1997
I have the "dim oil light" problem after 5 minutes of driving.

Quote:
Originally Posted by randall View Post
The oil light of my 1995 740i comes on a min or 2 after starting it starting out very dim and gradually brightens. There's no warning message on my display. Is this oil pressure switch variable or just a on-off switch? Any advise PLEASE.
I have the same problem. Have changed oil. Noticed that the oil sending unit has two pins (plus ground presumably). Wondering why?

Thanks.

John
  Reply With Quote
Old 07-11-2011, 07:21 AM   #4
randall

Name: randall
Title: United Newb
Status: Offline
Join Date: Jun 2010
Location: cape town
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 1995
Quote:
Originally Posted by balwit View Post
I have the same problem. Have changed oil. Noticed that the oil sending unit has two pins (plus ground presumably). Wondering why?

Thanks.

John
Hey John , not sure bout the 2 pins.... I change my oil switch and that solved my problem.
  Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Yellow "Low Oil" Light doughboyea E46 19 04-06-2011 07:45 PM
Help with e39 oil service light reset Graeme Taylor 5-Series 0 11-13-2009 04:34 AM
LIGHTING FAQ and lTUTORIAL habbie Lighting DIY's 0 09-24-2007 01:33 AM
Oil Service light? Alpine328i E36 13 03-05-2007 01:20 PM
History of gasoline! what is gas? and why it is NOT gasoline we pay for at the pump? delmarco United Off Topic  **FOR MEMBERS ONLY** 4 11-28-2005 03:29 PM


All times are GMT -5. The time now is 06:10 AM.

A vBSkinworks Design

 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright © 2005-2013 UnitedBimmer.com