Go Back   United Bimmer Community - BMW Forum > UnitedBimmer- Model Categories > 5-Series > E12, E28, E34, E39, E60
FAQ Members List Calendar Advertise With Us Mark Forums Read

E12, E28, E34, E39, E60 General discussion and technical help for all year 5 series cars.

Reply
 
Thread Tools
Old 11-17-2009, 09:14 AM   #1
macky55e34lover
 
macky55e34lover's Avatar

Name: macky55e34lover
Title: Member
Status: Offline
Join Date: Dec 2007
Location: Philippines
User not setup in Rate My Car.
Click here to set it up.
Your Ride: BMW '94 E-34 525i
Cool Hard starting M50

I have a '94 525i-M50, apparently, the car is hard to start at times, even if you were able to use it already. It will take around 3-5 times before the engine would run. I use it everyday and it is a good drive specifically on the highway. A concerned friend also saw the problem and told me that the crank sensor may be faulty and that I invest in getting a CAN-OBD II(diagnostics) to spot where the trouble is. Are we in the right direction? Any expert opinions will truly be valued. Help pleeeaasssseee.
  Reply With Quote
Old 11-17-2009, 10:35 AM   #2
3050rpm
 
3050rpm's Avatar

Name: 3050rpm
Title: Senior Member
Status: Offline
Join Date: Jul 2006
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 1995 325i
Well, not an expert, but I can offer these suggestions... When was the fuel filter last changed? That should be done yearly. Same with air filter. The fuel pump should also be checked, although I think that's more in the working/not working category. Vacuum leak?

OBD II didn't enter the picture until the 1996 model year, so I'm rather certain that your car is OBD I. I don't know if OBD II incorporates I, so if you go that route be sure to check exactly what you need before shelling out money.
  Reply With Quote
Old 11-18-2009, 06:26 PM   #3
macky55e34lover
 
macky55e34lover's Avatar

Name: macky55e34lover
Title: Member
Status: Offline
Join Date: Dec 2007
Location: Philippines
User not setup in Rate My Car.
Click here to set it up.
Your Ride: BMW '94 E-34 525i
i already replaced the fuel filter and air filter, fuel pump i agree needs to be checked, how about the crank sensor? is it connected to the problem?

thank you very much!
  Reply With Quote
Old 11-18-2009, 10:14 PM   #4
3050rpm
 
3050rpm's Avatar

Name: 3050rpm
Title: Senior Member
Status: Offline
Join Date: Jul 2006
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 1995 325i
Don't ask me to explain it, but if the crankshaft position sensor doesn't send a signal to the engine control module, then it's a no-go. So that could be the problem. I think it can be checked electronically to see if it's functioning properly.
  Reply With Quote
Old 11-22-2009, 05:28 AM   #5
macky55e34lover
 
macky55e34lover's Avatar

Name: macky55e34lover
Title: Member
Status: Offline
Join Date: Dec 2007
Location: Philippines
User not setup in Rate My Car.
Click here to set it up.
Your Ride: BMW '94 E-34 525i
Thank you very much man! I will have it checked this week! OBD-the works, everything
  Reply With Quote
Old 02-28-2010, 02:54 AM   #6
macky55e34lover
 
macky55e34lover's Avatar

Name: macky55e34lover
Title: Member
Status: Offline
Join Date: Dec 2007
Location: Philippines
User not setup in Rate My Car.
Click here to set it up.
Your Ride: BMW '94 E-34 525i
thank you for all of the advice, had the computer checked - no faults on this, the problem was pinpointed to the fuel pump and the crank sensor as well, i changed the air carbon canister as well as i can smell fuel in the car. the car runs sweet now.
  Reply With Quote
Old 08-18-2011, 06:01 AM   #7
LindaWens

Name: LindaWens
Title: United Newb
Status: Offline
Join Date: Aug 2011
Location: USA
User not setup in Rate My Car.
Click here to set it up.
Your Ride: Camry
thank you for all of the advice It's really useful.
__________________
baltimore bmw

Last edited by LindaWens; 08-18-2011 at 06:04 AM..
  Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
1986 e30 intermittent starting problem...plz help!! black325es E21, E30 3 07-22-2009 07:11 PM
E30 Problems: Hard Starting and Steering Noise BMWFreak E21, E30 0 03-08-2008 01:29 AM
MAJOR PROBLEM - Starting Car!!!! HELP!!! projal147 E36 12 09-07-2006 11:18 AM
M50 Manifold komodo E36 43 05-22-2005 07:31 PM


All times are GMT -5. The time now is 07:05 AM.

A vBSkinworks Design

 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright © 2005-2013 UnitedBimmer.com