Go Back   United Bimmer Community - BMW Forum > UnitedBimmer- Model Categories > 5-Series > E12, E28, E34, E39, E60
FAQ Members List Calendar Advertise With Us Mark Forums Read

E12, E28, E34, E39, E60 General discussion and technical help for all year 5 series cars.

Reply
 
Thread Tools
Old 09-04-2009, 09:15 PM   #1
soho325i
 
soho325i's Avatar

Name: soho325i
Title: United Newb
Status: Offline
Join Date: Sep 2009
Location: texas
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 95 bmw 525i
misfiring on acceleration

I am new to the site and this is my first post, so if I am not following protcol let me know.

1995 525i

Having issues when i give the car gas it mis-fires. My son changed the plugs and fuel filter. one of the plugs was broken and also oil was on one of the plugs. can any tell me what could be wrong.

thanks
  Reply With Quote
Old 09-05-2009, 09:18 AM   #2
3050rpm
 
3050rpm's Avatar

Name: 3050rpm
Title: Senior Member
Status: Offline
Join Date: Jul 2006
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 1995 325i
A very quick response... Make sure the plugs are factory spec (I believe either Bosch or NGK), DON'T put in anything else, whether platinum, gold, silver, uranium, or whatever. If there's oil in the spark plug wells, sop it up, and change the valve cover gasket. Sounds as if this car has been overdue for some other maintenance as well, but these suggestions are a start.
  Reply With Quote
Old 09-06-2009, 09:41 AM   #3
Big Evil
 
Big Evil's Avatar

Name: Big Evil
Title: Moderator
Status: Offline
Join Date: Nov 2008
Location: Tempe, Az
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 1994 BMW 525i, 1987 325is, 1986 325
3050 is right, and when posting try to make sure you get it in the right category. You'll get better and faster responses. Let us know how it turns out.
__________________
Big Evil, The BMW driving monster of the American Southwest (Currently on BMW #5)
  Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Clicking sound during acceleration mrkbik E36 18 11-16-2007 10:13 PM
Acceleration lags DBB E21, E30 9 05-10-2007 11:22 PM
FWD vs RWD komodo United Off Topic  **FOR MEMBERS ONLY** 35 07-14-2005 10:18 AM


All times are GMT -5. The time now is 07:59 AM.

A vBSkinworks Design

 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright © 2005-2013 UnitedBimmer.com