Go Back   United Bimmer Community - BMW Forum > UnitedBimmer- Model Categories > E46
Register FAQ Members List Calendar Advertise With Us Mark Forums Read

E46 General discussion and technical help for 1999-2004 3 series cars.

Reply
 
Thread Tools
Old 04-15-2009, 02:08 PM   #1
havensmom07
 
havensmom07's Avatar

Name: havensmom07
Title: United Newb
Status: Offline
Join Date: Apr 2009
Location: Tennessee
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 99 328i
so so lost.....

Ok...so I'll start with this. I have a 99 328i 98k....has been an awesome car....then on Monday it just decided to flip out on me. I started it that morning...it did some random idling....was fine when I put the car in gear. After about 2 miles it just started shaking and missing really reallllllly bad. So....I called the BMW guy....he said clean the ICV.....done.....did NOT work...he said check your head gasket....done....did NOT work....he said replace s.plugs and check coil packs....done....did NOT work....so WTF? BMW guy is at a loss himself without cracking into it and well....I do NOT have the money to let him do that right now.....

About a month ago I replaced 2 o2 sensors because codes check said it needed it.....Is is the camshaft sensor? What else can I check to figure out what my babies illness is?

Please help. I really would appreciate it!!! And plz dont be a dick to me.
  Reply With Quote
Old 04-15-2009, 03:57 PM   #2
m3m3m3

Name: m3m3m3
Title: Sitting in Time out
Status: Offline
Join Date: Aug 2007
User not setup in Rate My Car.
Click here to set it up.
Quote:
Originally Posted by havensmom07 View Post
Ok...so I'll start with this. I have a 99 328i 98k....has been an awesome car....then on Monday it just decided to flip out on me. I started it that morning...it did some random idling....was fine when I put the car in gear. After about 2 miles it just started shaking and missing really reallllllly bad. So....I called the BMW guy....he said clean the ICV.....done.....did NOT work...he said check your head gasket....done....did NOT work....he said replace s.plugs and check coil packs....done....did NOT work....so WTF? BMW guy is at a loss himself without cracking into it and well....I do NOT have the money to let him do that right now.....

About a month ago I replaced 2 o2 sensors because codes check said it needed it.....Is is the camshaft sensor? What else can I check to figure out what my babies illness is?

Please help. I really would appreciate it!!! And plz dont be a dick to me.
is the check engine light on? do you have a code reader? any errors?
  Reply With Quote
Old 04-15-2009, 05:15 PM   #3
havensmom07
 
havensmom07's Avatar

Name: havensmom07
Title: United Newb
Status: Offline
Join Date: Apr 2009
Location: Tennessee
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 99 328i
Quote:
Originally Posted by m3m3m3 View Post
is the check engine light on? do you have a code reader? any errors?
It was on. It read bad o2 sensor. I replaced it and now its off but it is still shaking and missing.......
__________________
Mis_T
  Reply With Quote
Old 04-16-2009, 01:21 AM   #4
Kistoni

Name: Kistoni
Title: Member
Status: Offline
Join Date: Aug 2006
Location: Suva Fiji South Pacific
Rate My Car: 236 / 340
Your Ride: 316i '95
If it is just on idle it could be a vacuum leak. Check for whistling noise from under the hood. Check all rubber hoses and bellows on air intake. When you were told to check the head gasket they probably meant the valve cover gasket as this is also prone to leaks. A vacuum leak could have caused the O2 sensors to fail as it would make the engine to run rich and fowl the sensors.

Good luck and let us know how you get on.
  Reply With Quote
Old 04-16-2009, 11:26 AM   #5
havensmom07
 
havensmom07's Avatar

Name: havensmom07
Title: United Newb
Status: Offline
Join Date: Apr 2009
Location: Tennessee
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 99 328i
A few months ago I did have to replace a worn hose but we have checked and rechecked all the hoses. Today I'm replacing the valve cover gasket even though it doesnt seem to be the problem, I just figure I'll replace it all while I've got it apart.
Thanks!!!
__________________
Mis_T
  Reply With Quote
Old 04-20-2009, 03:56 AM   #6
Maxi
 
Maxi's Avatar

Name: Maxi
Title: Member
Status: Offline
Join Date: Dec 2007
Location: Qatif-Awam
User not setup in Rate My Car.
Click here to set it up.
Your Ride: BMW E46 328i 99
Hi, any update?!!
__________________
Maximum Power
  Reply With Quote
Old 04-20-2009, 12:43 PM   #7
havensmom07
 
havensmom07's Avatar

Name: havensmom07
Title: United Newb
Status: Offline
Join Date: Apr 2009
Location: Tennessee
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 99 328i
Well....parts replaced.....valve cover gasket, another o2 sensor and coils 1&6......she's back to her wonderful self again! Yay!!!!
__________________
Mis_T
  Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Forum DOWN TIME and LOST DATA scooter United Off Topic  **FOR MEMBERS ONLY** 1 10-24-2008 06:31 AM
I got lost trying to compare all the MP3 models so.... dennis1 Geek Chat 3 07-11-2007 01:49 AM
i lost my voice Hoppy United Off Topic  **FOR MEMBERS ONLY** 10 01-07-2006 10:19 AM
Lost Topic bmw4life Site Feedback 24 12-10-2005 04:19 PM
Japan Space Robot "Minerva" Lost in Space komodo United Off Topic  **FOR MEMBERS ONLY** 1 11-15-2005 12:09 AM


All times are GMT -5. The time now is 01:13 PM.

A vBSkinworks Design

 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright © 2005-2013 UnitedBimmer.com