Go Back   United Bimmer Community - BMW Forum > UnitedBimmer- Model Categories > 5-Series > E12, E28, E34, E39, E60
FAQ Members List Calendar Advertise With Us Mark Forums Read

E12, E28, E34, E39, E60 General discussion and technical help for all year 5 series cars.

Reply
Thread Tools
Unread 01-17-2009, 06:14 PM   #1
QcMarque
 
QcMarque's Avatar

Name: QcMarque
Title: Member
Status: Offline
Join Date: Oct 2006
Location: Puyallup, WA
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 1994 740i
Send a message via ICQ to QcMarque Send a message via AIM to QcMarque Send a message via MSN to QcMarque Send a message via Yahoo to QcMarque
Question ECU Issues?

So I was doing some research and found that the stock ECU (#1 267 355 796) doesn't have an upgraded version (BavAuto, FunCar.ru, etc I'm unable to find anything)... though I'm told the car I just bought has an upgraded/performance ECU in it, and the stock EEPROM is in the glove box.

Curious, I went to pull the ECU but didn't have the sockets to do it. I plugged it back in and went about my evening. Next time I started the car (or even turn the ignition on) it runs through a bunch of diagnostics stuff (Software Ver, BMW NR, some other NR thing, and some other stuff), the dials run up and back down, then the display goes solid and doesn't change.

To me, this seems most peculiar and it shouldn't do that. Any thoughts? I'm going to go ahead and pull the ECU and open it up, put the stock EEPROM back in and see what she does.

I do have a BavAuto code reader and it's not throwing any codes... so I'm a little stumped.


Thanks everyone!
__________________
Canadian by blood... German by ride
  Reply With Quote
Unread 01-27-2009, 02:58 PM   #2
QcMarque
 
QcMarque's Avatar

Name: QcMarque
Title: Member
Status: Offline
Join Date: Oct 2006
Location: Puyallup, WA
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 1994 740i
Send a message via ICQ to QcMarque Send a message via AIM to QcMarque Send a message via MSN to QcMarque Send a message via Yahoo to QcMarque
Here's the information that the display shows everytime I turn the key to Position 2(doesn't matter if I start the car or not):

BMW NR 1388757
CODE NR 23096
K-ZHAL 7296
F.G. NR BF 09611
SW VER 0.83
ND INDEX 08


If I put the ignition in Position 1 and leave it for about 8-10 seconds the dash display changes languages (English US, English UK, French, Itanian, Spanish, German). It only changes 1 language at a time, so I have to keep turning the key off and on to get it back to English.
__________________
Canadian by blood... German by ride
  Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ecu problem..realy need advice fourtwenty E36 5 01-20-2008 03:24 PM
M42 318 Wont Start. ECU problems? Numark318i E21, E30 3 10-14-2007 03:08 PM
ECU location maximk2 E36 3 05-27-2007 12:57 PM
Time for a new ECU DME POS_BMW E36 8 07-10-2006 03:08 PM
Update on cams, advice on ECU PLS Rooz E36 71 09-05-2005 08:16 PM


All times are GMT -5. The time now is 03:34 PM.

A vBSkinworks Design

 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Copyright © 2005-2013 UnitedBimmer.com