Go Back   United Bimmer Community - BMW Forum > UnitedBimmer-General BMW Topics > BMW General Discussion
FAQ Members List Calendar Advertise With Us Mark Forums Read

BMW General Discussion Sponsored by: AutohausAZ.com
Talk about BMWs in general. Post official news, Bangle flames, or anything else related to BMW.

Reply
 
Thread Tools
Old 03-22-2008, 02:29 PM   #1
f0rbes

Name: f0rbes
Title: United Newb
Status: Offline
Join Date: Mar 2008
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 1986 524td
Vacuum problem

Hi, I am new to these forums as I just came across them today . Anyways I have a minor problem that I need advice on fixing. Basically I have a 1986 524td. My problem is that my brakes arent getting enough vacuum and its causing my brakes to be very squishy so i have to really stomp to get my brakes working. I have realized that maybe the brakes arent getting enough vacuum because maybe the booster is recieving most of it to help get better performance because let me say, for a diesel this thing runs like a beauty.

What I was thinking was installing a seperate vacuum pump where i have extra space (already found the perfect spot) and hooking it up to where all i need to do is flip a switch or somesort if I find my brakes are getting squishy and it turns the vacuum on and then a couple seconds later I turn it off and my brakes are fine and so on and so forth. But I was also trying to think of a way to make it run automatically.

Basically I am wondering of any other possible solutions or maybe any advice on fixing my brakes. Thanks.
  Reply With Quote
Old 03-22-2008, 02:36 PM   #2
witeshark
 
witeshark's Avatar

Name: witeshark
Title: Suspended License
Status: Offline
Join Date: Apr 2005
Location: Miami FL
Rate My Car: 84 / 340
Your Ride: 89 325i 5 speed
Have you tried replacing the brake fluid? I'd also try bleeding the system for air and checking for leaks.
  Reply With Quote
Old 03-22-2008, 02:45 PM   #3
johnnybayonne
 
johnnybayonne's Avatar

Name: johnnybayonne
Title: Suspended License
Status: Offline
Join Date: Jun 2007
Rate My Car: 254 / 340
Your Ride: 1997 328i
Quote:
Originally Posted by f0rbes View Post
Hi, I am new to these forums as I just came across them today . Anyways I have a minor problem that I need advice on fixing. Basically I have a 1986 524td. My problem is that my brakes arent getting enough vacuum and its causing my brakes to be very squishy so i have to really stomp to get my brakes working. I have realized that maybe the brakes arent getting enough vacuum because maybe the booster is recieving most of it to help get better performance because let me say, for a diesel this thing runs like a beauty.

What I was thinking was installing a seperate vacuum pump where i have extra space (already found the perfect spot) and hooking it up to where all i need to do is flip a switch or somesort if I find my brakes are getting squishy and it turns the vacuum on and then a couple seconds later I turn it off and my brakes are fine and so on and so forth. But I was also trying to think of a way to make it run automatically.

Basically I am wondering of any other possible solutions or maybe any advice on fixing my brakes. Thanks.
If you had a vacuum problem with the brakes & brake booster, you would have a stiff pedal or find it difficult to press down on the brake pedal! Squishy brakes sounds like air in the brake system or bad master cylinder!
http://autorepair.about.com/od/troub...s_brakes_2.htm
http://autorepair.about.com/od/troub...s_brakes_4.htm

Last edited by johnnybayonne; 03-22-2008 at 02:49 PM..
  Reply With Quote
Old 03-22-2008, 06:58 PM   #4
f0rbes

Name: f0rbes
Title: United Newb
Status: Offline
Join Date: Mar 2008
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 1986 524td
Its hard to explain what kind of feeling i get when I press on the Pedal but basically It feels like I am just not gettign enough vacuum to the brakes. Ive replaced all the hoses with new ones and there isnt any blockage or holes/leaks. I was going to do brake fluid once the weather got a little nicer and from the reciepts the booster is fairly new. oh and the brakes are firm not sqishy my fault on that.

Last edited by f0rbes; 03-22-2008 at 07:45 PM..
  Reply With Quote
Old 03-22-2008, 10:44 PM   #5
JetBlack328i
 
JetBlack328i's Avatar

Name: JetBlack328i
Title: Member
Status: Offline
Join Date: Feb 2008
Location: Oahu, Hawaii
Rate My Car: 69 / 340
Your Ride: 96 328i
Quote:
Originally Posted by johnnybayonne View Post
If you had a vacuum problem with the brakes & brake booster, you would have a stiff pedal or find it difficult to press down on the brake pedal! Squishy brakes sounds like air in the brake system or bad master cylinder!
+1 check for air in the lines or a bad master cylinder
__________________
  Reply With Quote
Old 03-23-2008, 01:38 PM   #6
m3flyer
 
m3flyer's Avatar

Name: m3flyer
Title: Member
Status: Offline
Join Date: Oct 2007
Location: America
Rate My Car: 3 / 340
Your Ride: 1) Alpinweiss 1989 M3 2) Diamondswartz 1989 M3
Thumbs up Ding !!

Quote:
Originally Posted by johnnybayonne View Post
If you had a vacuum problem with the brakes & brake booster, you would have a stiff pedal or find it difficult to press down on the brake pedal! Squishy brakes sounds like air in the brake system or bad master cylinder!
http://autorepair.about.com/od/troub...s_brakes_2.htm
http://autorepair.about.com/od/troub...s_brakes_4.htm
2nd.

Johnny is correct.

Although loss of the booster entirely may result in weak pedal as well.

Also... check the master cylnder.

Try a synthetic Dot4/5 fluid and flush 'til the bubbles disappear.
__________________
Carpe Diem
  Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
A Known Instrument Cluster Problem KickingKing E36 6 11-16-2011 08:50 PM
328is problem, runs weird - Vacuum hose leak? something clogged? peterkdenny E36 4 02-16-2008 10:27 PM
325 brake light problem fgmx Lighting 2 02-01-2008 01:52 PM
e36 convert problem Butcher E36 3 09-07-2007 05:24 PM
528I gear problem, Please help me guys, plz plz djfactor E12, E28, E34, E39, E60 3 10-22-2006 05:56 PM


All times are GMT -5. The time now is 11:28 PM.

A vBSkinworks Design

 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright © 2005-2013 UnitedBimmer.com