Go Back   United Bimmer Community - BMW Forum > UnitedBimmer-General BMW Topics > BMW General Discussion
FAQ Members List Calendar Advertise With Us Mark Forums Read

BMW General Discussion Sponsored by: AutohausAZ.com
Talk about BMWs in general. Post official news, Bangle flames, or anything else related to BMW.

Reply
 
Thread Tools
Old 03-13-2008, 08:19 AM   #1
Colino191

Name: Colino191
Title: United Newb
Status: Offline
Join Date: Mar 2008
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 02 BMW 530 diesel estate
530D power problem

Hi guys first post. I have a 530d estate and yesterday the engine lost power when i tried to accelerate. Seems fine when taking it easy but as soon as the foot goes down it jumps and stutters and is completely flat. I'm not a techno type person but would guess fuel management. Any ideas?
  Reply With Quote
Old 03-13-2008, 08:48 AM   #2
witeshark
 
witeshark's Avatar

Name: witeshark
Title: Suspended License
Status: Offline
Join Date: Apr 2005
Location: Miami FL
Rate My Car: 84 / 340
Your Ride: 89 325i 5 speed
Maybe the injectors need cleaning.
  Reply With Quote
Old 03-13-2008, 09:20 AM   #3
Colino191

Name: Colino191
Title: United Newb
Status: Offline
Join Date: Mar 2008
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 02 BMW 530 diesel estate
I have asked the garage to check it out. They say it isn't the turbo air inlet pipe collapsing and think it is maybe the fuel pump on it's way out. I would have thought the fuel pump would work then not work. This seems to be a progressive problem as i can drive fine without maxxing the accelerator. As i said before i'm not technical and only guessing. Thanks for the reply.
  Reply With Quote
Old 03-13-2008, 09:44 AM   #4
witeshark
 
witeshark's Avatar

Name: witeshark
Title: Suspended License
Status: Offline
Join Date: Apr 2005
Location: Miami FL
Rate My Car: 84 / 340
Your Ride: 89 325i 5 speed
A progressive fuel pump issue makes a lot of sense from the performance you described.
  Reply With Quote
Old 03-13-2008, 10:10 AM   #5
Colino191

Name: Colino191
Title: United Newb
Status: Offline
Join Date: Mar 2008
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 02 BMW 530 diesel estate
Thanks.The problem only started yesterday. It's been in the garage most of today. I suppose this is the problem with modern engines. More and more reliance on electronic systems for diagnosis of faults.
  Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
power hood problem shamrock328 E36 1 01-07-2010 03:21 AM
power window problem TheUniballer Car Audio and Electronics 1 06-01-2007 04:37 AM
Greetings! power lock problem Cabrini Introductions and Greetings 2 02-13-2007 09:54 AM
Power Lock problem nick_318is E21, E30 9 09-09-2006 10:46 PM
weird CEL... ivopivo E36 46 03-22-2006 01:22 PM


All times are GMT -5. The time now is 06:58 PM.

A vBSkinworks Design

 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright © 2005-2013 UnitedBimmer.com