Go Back   United Bimmer Community - BMW Forum > UnitedBimmer- Model Categories > E36
FAQ Members List Calendar Advertise With Us Mark Forums Read

E36 General discussion and technical help for (E36) 1992-1999 3 series cars. 318, 323, 325, 328.

Reply
 
Thread Tools
Old 11-13-2007, 12:18 PM   #1
volvodefector79

Name: volvodefector79
Title: United Newb
Status: Offline
Join Date: Nov 2007
Location: the Windy City
Rate My Car: 303 / 340
Your Ride: 1995 525i
OK - getting codes, CHECK ENGINE light works, but it's not on!

Any ideas? My check engine light now WORKS, as I replaced the burnt out bulb and it activates when starting. It turn off, however, and does not come on.

Here's the tricky part. Some of the time - NOT all of the time - the idle will be poor, like it's missing. Then the idle will hunt (though not missing) - still, no check engine light. AND these symptoms are not constant. They are intermittent and irregular. They do occur more often when the engine is warm, however. Actually, the only times it has "missed" is when the engine is very warm, it's sat for about 30 minutes or so, and upon restarting.

Fuel consumption is normal. It is not lower, nor has it incresed.

Now despite the fact that the check engine light isn't popping on, I still am frequently hooking up my OBD-II to troubleshoot. It is reading current and stored codes for fuel trim: bank 1 & fuel trim: bank 2.

I've tried fuel additives Techron fuel system cleaner w/premium petrol (twice). I've also replaced the MAF (mass air flow) sensor, yet it still gives me the codes. I'm thinking may be O2 sensor(s)???

Anybody - ideas? They're much appreciated!!!
  Reply With Quote
Old 11-13-2007, 06:46 PM   #2
volvodefector79

Name: volvodefector79
Title: United Newb
Status: Offline
Join Date: Nov 2007
Location: the Windy City
Rate My Car: 303 / 340
Your Ride: 1995 525i
Nevermind...

It must have taken a bit for the ECU to recognize the faults again after I cleared the codes (and replaced the lamp). Duh! The light has come on since. I don't know why I'm happy about that...

Still getting the same codes. Can anybody tell me if fuel trim bank 1 & 2 indicate the upstream 02 sensors???
  Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Check engine light??? SHAHAB323IS E36 30 08-11-2011 12:50 PM
How to fix/reconnect check engine light??? volvodefector79 E36 2 11-13-2007 06:50 PM
check engine light mzbmw325i E21, E30 4 08-26-2007 01:18 AM
Red Check Engine Light browneyedgirl E12, E28, E34, E39, E60 16 03-17-2007 03:50 PM
BMW Inspection Rooz BMW General Discussion 21 03-14-2006 02:10 PM


All times are GMT -5. The time now is 06:33 PM.

A vBSkinworks Design

 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright © 2005-2013 UnitedBimmer.com