Go Back   United Bimmer Community - BMW Forum > UnitedBimmer- Model Categories > 7 Series (E23, E32, E38, E65, E66)
FAQ Members List Calendar Advertise With Us Mark Forums Read

7 Series (E23, E32, E38, E65, E66) General discussion and technical help for all year 7 series cars.

Reply
 
Thread Tools
Old 05-20-2005, 12:08 AM   #1
pyro

Name: pyro
Title: United Newb
Status: Offline
Join Date: May 2005
User not setup in Rate My Car.
Click here to set it up.
instrument cluster and heater controlls...

Hi,
my instrument cluster dosn't light up at night and i cant figure out what is causing it... i repplaced the dimmer swich and all of the bulbes in the instrument cluster... nothing iluminates at all... need some help
  Reply With Quote
Old 05-20-2005, 01:16 AM   #2
breden

Name: breden
Title: Member
Status: Offline
Join Date: Apr 2005
Location: santa barbara
Rate My Car: 36 / 340
did you try the fuses?
  Reply With Quote
Old 05-20-2005, 05:16 PM   #3
pyro

Name: pyro
Title: United Newb
Status: Offline
Join Date: May 2005
User not setup in Rate My Car.
Click here to set it up.
that was the first thing i checked and none of em are blown i even rapplaced all of the fuses with smart fuses
  Reply With Quote
Old 05-20-2005, 09:52 PM   #4
komodo
 
komodo's Avatar

Name: komodo
Title: Administrator
Status: Offline
Join Date: Apr 2005
Location: Athens, GA
Rate My Car: 68 / 340
Your Ride: 1995 M3
I had the same problem and it ended up being the fuse... if you've checked that and it's not it, maybe the bulb behind the cluster?

And the obvious, check the dial for dimness to make sure you didn't hit it and knock into it all the way dim.

When I had my problem before I knew it was the fuse, someone suggested the headlights switch. If the connection is getting bad, it might not touch that part correctly, but still turn on the headlights. This is a bit far out I think, but it was suggested to me.

Anything beyond that is probably an electrical issue. =/
__________________

  Reply With Quote
Old 05-21-2005, 04:20 PM   #5
pyro

Name: pyro
Title: United Newb
Status: Offline
Join Date: May 2005
User not setup in Rate My Car.
Click here to set it up.
well iv checked and its not the swich or the dimmer its a short somewhere... so what color is the wire that iluminates everything? what is supost to be ilumintated so i can check if maby a wire is lose causeing it...
  Reply With Quote
Old 05-29-2005, 12:38 PM   #6
pyro

Name: pyro
Title: United Newb
Status: Offline
Join Date: May 2005
User not setup in Rate My Car.
Click here to set it up.
well still no luck any more ideas...?
  Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:50 AM.

A vBSkinworks Design

 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright © 2005-2013 UnitedBimmer.com