Go Back   United Bimmer Community - BMW Forum > UnitedBimmer- Model Categories > E46
FAQ Members List Calendar Advertise With Us Mark Forums Read

E46 General discussion and technical help for 1999-2004 3 series cars.

Reply
 
Thread Tools
Old 05-08-2007, 08:51 AM   #1
Char-Don-Eh!

Name: Char-Don-Eh!
Title: United Newb
Status: Offline
Join Date: May 2007
Location: Washington, DC
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 2004 BMW 325ci
Unhappy 2004 325ci RED Oil Pressure Light

Just got this car about a month ago--51,000 miles; driving to work last week and the little red oil can starts flickering on and off. I drove another block to get to a safe place and shut the car down and called BMW roadside rescue. They came and towed the car to the BMW dealer; they hooked it up to their computer--told them to replace the Oil Pressure Sending Unit--so that's what they did. $250 later I'm driving the car home that evening and after about 20 miles the damn light goes on again--but only when I'm braked to almost a dead stop. As soon as I step on the gas the light goes out. I called the dealer and they said to bring it by the next day so I did. Once again, they check car over, did a pressure test--all okay and the mechanic even drove it home that evening trying to duplicate the problem--finally came on//flickering after about 20 miles and then would go on and off while slowing down but upon stepping on the gas--light goes off and stays off. Dealer claims they've never seen this problem--I bought an extended warranty for the car (thank god) that kicks in this week. Can't imagine what this could be--I've read many threads--say change the wiring harness and the sending unit--another mechanic says it could be the idiot light on the dashboard--my good sense tells me maybe the oil pump? Hell--I'm a woman--I know enough to be dangerous. I was looking forward to a problem free BMW (yes, I know I'm dreaming--hell this is my 3rd BMW convertible--had 318i, 328i and now this--and all they ever did was have the Check Engine light come on--go figure, I spend lots more money and now this. I just don't want to puke the engine on the way to get it fixed. HELP!

Last edited by Char-Don-Eh!; 05-08-2007 at 12:26 PM..
  Reply With Quote
Old 05-08-2007, 09:09 AM   #2
Numark318i
 
Numark318i's Avatar

Name: Numark318i
Title: has an empty wallet
Status: Offline
Join Date: Apr 2005
Location: The Only place in the world where people say "Hella"
Rate My Car: 125 / 340
Your Ride: ^^
my 2001 330's oil level sending unit went out. Sometimes the red oil light would come on. Randomly as you describe. I swapped it out (its a $75 part...ye they charge you 150. Who cares you have the warranty) and its good as new. No more oil light.


so, my guess would be oil sender.
__________________
We all get the urge...Saturday early morning...nothing to do till noon... BMW FTW

The aural sensations of 1st gear WOT
**CGM **(Certified Garage Mechanic)
  Reply With Quote
Old 05-08-2007, 12:20 PM   #3
Char-Don-Eh!

Name: Char-Don-Eh!
Title: United Newb
Status: Offline
Join Date: May 2007
Location: Washington, DC
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 2004 BMW 325ci
That's what I thought too, but the first time I took it in, the BMW dealer replaced it and I still have the problem. In fact, it seems to be getting worse (as in comes on more frequently than it did in the beginning.) It would be too weird to have two defective sending units wouldn't it? I suppose it can happen.
  Reply With Quote
Old 05-08-2007, 12:43 PM   #4
Numark318i
 
Numark318i's Avatar

Name: Numark318i
Title: has an empty wallet
Status: Offline
Join Date: Apr 2005
Location: The Only place in the world where people say "Hella"
Rate My Car: 125 / 340
Your Ride: ^^
yea it does seem weird..but im sure its possible.

my sender unit went out the day after i went to the dealership...so.kinda odd In my opinion
__________________
We all get the urge...Saturday early morning...nothing to do till noon... BMW FTW

The aural sensations of 1st gear WOT
**CGM **(Certified Garage Mechanic)
  Reply With Quote
Old 11-02-2007, 09:04 PM   #5
Stephane Morali

Name: Stephane Morali
Title: United Newb
Status: Offline
Join Date: Nov 2007
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 2004
E46 2004 325 Ci Convertible - red oil light flickers when idle/stopped

I just got a 325 Cic 2004 (built in 2003) with 42800 miles. Soon after driving the car off the dealer parking lot the red oil light started flickering when idle / stopped at traffic light. In other words I'm having same exact problem.
I took the car to Stevens Creek BMW in San Jose to resolve. They said oil was contaminated with moisture which caused the light to be on. They changed oil and scanned for faults but didn't find any.
Light stopped coming for 3 days and came back on in same conditions when idle / stopped in traffic basically when engine idle.
Have you fixed your problem?
  Reply With Quote
Old 11-25-2007, 10:23 PM   #6
Sal

Name: Sal
Title: United Newb
Status: Offline
Join Date: Nov 2007
User not setup in Rate My Car.
Click here to set it up.
Your Ride: E46
Same problem

I have the exact same problem....I just wasted 150 when my mechanic incorrectly thought it was the oil level sensor, moron!....he then changed the oil pressure sensor for free (an $11 part) which just verified that that sensor was fine. His final thought was it was the oil pump, a $600 estimate. Anyways, no more wasting my time with that general mechanic.

My red light flickering (at idle) started the day of my last oil change, about 2500 miles ago. I'm thinking I'm going to take it to the dealer now. Cars got 115K.....so far it's been pretty good.

Did anyone successfully solve their problem? Thanks.

Last edited by Sal; 11-25-2007 at 10:28 PM..
  Reply With Quote
Old 12-02-2007, 11:41 PM   #7
Sal

Name: Sal
Title: United Newb
Status: Offline
Join Date: Nov 2007
User not setup in Rate My Car.
Click here to set it up.
Your Ride: E46
oh...I also noticed it only begins to flicker at idle once the car is warmed up, dead center thermostat reading. Anyone ever figure it out?
  Reply With Quote
Old 12-03-2007, 05:24 PM   #8
Antiburn
 
Antiburn's Avatar

Name: Antiburn
Title: Senior Member
Status: Offline
Join Date: Apr 2005
Location: Jersey
Rate My Car: 193 / 340
Your Ride: 92 525, 88 325 hardtop'ed vert and 83 320iS
The oil level senders on the e46's always have problems, so with the tech replacing that first is the most senseable thing. Ive never seen an oil pressure switch go on them but theres always a first. Also change the oil at the same time, like said before it can be contaminated.
There could also be some road debris or moisture in the connector causing it to happen. Not likely but possible.
And lastly the engine harness could be faulty causing the light to come on. Theres not many other things that factor into the light comming on other then low oil level.
__________________
1992 525i, 1988 Hardtop'ed Vert and 1983 320iS
  Reply With Quote
Old 12-03-2007, 10:28 PM   #9
TECH

Name: TECH
Title: United Newb
Status: Offline
Join Date: Dec 2007
User not setup in Rate My Car.
Click here to set it up.
Your Ride: Sick cars.
The red light would be the pressure switch, the yellow would be the level sensor. Make sure the shop put the right part in. The switch is on the back of the oil filter housing, and the level sensor is in the bottom of the oil pan.
If the light only comes on at idle, or low rpm, then I'd believe that the pressure is a bit low at idle (due to the oil pump turning slower), so I'd make sure the oil filter isn't plugged up with sludge. An oil change may be all it needs.
  Reply With Quote
Old 12-12-2007, 09:05 PM   #10
tnguyen724

Name: tnguyen724
Title: United Newb
Status: Offline
Join Date: Oct 2007
Location: Orlando, FL
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 2003 325i
Flashing oil pressure light problem continues.....

My 03 325i has the same symptoms as described by everyone above. I had my pressure sender replaced and oil/filter changed twice already. It only happens after the engine is warmed up and running for about 20 minutes when the engine is at idle speed. I tried Mobil One 10-30 oil which helped a little. I was told by a BMW mechanic that he's seen this on later BMW 3 series and to try Mobil One 20-50 oil and it can with stand the heat and increase compression.
  Reply With Quote
Old 12-23-2007, 01:34 AM   #11
moriantrajan
 
moriantrajan's Avatar

Name: moriantrajan
Title: United Newb
Status: Offline
Join Date: Dec 2007
Location: millbrook alabama
Rate My Car: 137 / 340
Your Ride: 2002 325 cic
hey tell your bimmer dealer to lay off the hardware and just swap out the damn sensor....when they look at you and say huhh ask them what your oil looks like if they say like we just changed it then none of these other recreational activities they are engaging in are worth your while...had and seen similiar problem on other bmr's in past..matter of fact have or had same one on the 02 certified i just bought it's most likely the sensor....let me know how it goes and good luck...j.lee
  Reply With Quote
Old 01-14-2008, 02:27 PM   #12
sikhestknight

Name: sikhestknight
Title: United Newb
Status: Offline
Join Date: Jan 2008
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 2004 330ci
I am having the exact same problem (330 ci, 2004). When the car is idling, the red oil light is flickering. Once you rev the rpm up a little, the light goes off. I just had an oil change done, thinking that would solve the problem, however it did not solve the issue. Any one solve this problem yet??? I hope so...please advise. Thanks.

  Reply With Quote
Old 01-22-2008, 07:04 PM   #13
tnguyen724

Name: tnguyen724
Title: United Newb
Status: Offline
Join Date: Oct 2007
Location: Orlando, FL
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 2003 325i
Mobil One 15-50 stopped the flashing oil light

I have switched to Mobil one 15-50 synthetic and have been running for several weeks now with no more flashing oil light at idle. I'm not sure if it covered up the problem or just an oversensitive engine. It sure is cheaper than replacing the oil pump or bearings in which the dealer wanted to perform. For the next oil change I will try 0-40w synthetic.
Good luck to everyone.
  Reply With Quote
Old 02-20-2009, 05:38 PM   #14
Louis64

Name: Louis64
Title: United Newb
Status: Offline
Join Date: Feb 2009
Location: New Zealand
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 320CI Rag-Top
Greetings to the UNITED BIMMER Community forum.


The above describes to the letter what I have with my 2002 320CI rag-top, which has done 80,000 Km. My mechanic went further to investigate the reason why the light was flickering, and created a temporary contraption to install an analog oil pressure gauge to determine the AMOUNT of pressure that's causing the light to come on. It was about 10psi, tending to 8psi at low revs, and with some load on the motor. All that was with a new Oil pressure sensor, new oil and filter, and no electrical faults.

When comparing the result above with another car (same motor) (Selected a car that's had a rough life) the oil pressure was still in the 20psi even at low revs. So, it was determined that the detection system was fine (the red light).. The Oil pressure WAS indeed low.

We are still wondering what could be the cause of this issue. Suspecting bad oil pump, oil pump gaskets, or an internal leak in the lube system that's causing the pressure drop.

Has anybody found a cause/solution to the problem?? or are you just happy to live with it?? Please post.
  Reply With Quote
Old 06-05-2009, 02:14 PM   #15
geccles

Name: geccles
Title: United Newb
Status: Offline
Join Date: Jun 2009
Location: Boston
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 2003
I have exactly the same issue since I had my oil leak fixed.

The original problem was a leak at the oil pressure sensor. This was replaced and low pressure indicator has been flickering since (only at low rpm).

The garage has since replaced the sensor again, the oil pump, the oil filter housing.

They are still digging but I'd love to hear from someone who has gotten to the bottom of this.
  Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
red light cameras bakaroo United Off Topic  **FOR MEMBERS ONLY** 4 11-09-2011 04:57 AM
oil pressure switch. chris325i E36 5 04-29-2007 10:15 PM
Red Check Engine Light browneyedgirl E12, E28, E34, E39, E60 16 03-17-2007 02:50 PM
Oil Service light? Alpine328i E36 13 03-05-2007 12:20 PM
blinking red light akinthecat E36 2 01-31-2007 07:16 PM


All times are GMT -5. The time now is 09:40 AM.

A vBSkinworks Design

 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright © 2005-2013 UnitedBimmer.com