Go Back   United Bimmer Community - BMW Forum > UnitedBimmer- Model Categories > E21, E30
Register FAQ Members List Calendar Advertise With Us Mark Forums Read

E21, E30 General discussion and technical help for 1975-1991 3 series cars.

Reply
 
Thread Tools
Old 03-04-2007, 06:10 PM   #1
Exilion
 
Exilion's Avatar

Name: Exilion
Title: Senior Member
Status: Offline
Join Date: Oct 2006
Location: World wide
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 1991 325i
a/c rpm problem

Hello everyone. Ok this is a problem I've avoided because I was busy and I didn't need to use the a/c in the winter. But now it's turning to spring and getting hot again. It's probably simple to diagnose but I wanted some outside advice as to what it was and how difficult it is to fix.

The problem is whenever I turn the a/c on the engine's rpm accelerates from idle to around 2000-2500 rpms. This obviously is not noticeable while the car is in gear but coming from a stop it can be annoying. All I can guess so far is that the idle control can't handle the strain of the a/c.

So... what do you think?
  Reply With Quote
Old 03-04-2007, 07:14 PM   #2
c1apton
 
c1apton's Avatar

Name: c1apton
Title: Upgraded Member
Status: Offline
Join Date: Oct 2005
Location: Pompano Beach,Fl /Edina,Mn
Rate My Car: 134 / 340
Your Ride: 93 E34
Normally when you turn on the AC the idle should go up to compensate for the AC load but not to 2000 to 2500 -that's not normal. It should only go up a couple hundred rpms. Do you own a Bentley manual? You need to check the specs for high idle settings
  Reply With Quote
Old 03-04-2007, 09:29 PM   #3
Exilion
 
Exilion's Avatar

Name: Exilion
Title: Senior Member
Status: Offline
Join Date: Oct 2006
Location: World wide
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 1991 325i
Unfortunately no and I lost my Hanes manual... I'll have to pick a new one up before I start again. I was doing pretty good using bimmerdiy.com
  Reply With Quote
Old 05-21-2007, 07:51 PM   #4
Bibolt

Name: Bibolt
Title: United Newb
Status: Offline
Join Date: May 2007
User not setup in Rate My Car.
Click here to set it up.
Your Ride: E301988
try replacing fuel pressure regulator, and try adjusting throttle position with the screw over the gas pedal wire, that worked for me,
even though my mech told me it had nothing to do with the fuel pressure regulator, it worked for me.
  Reply With Quote
Old 05-22-2007, 01:11 PM   #5
elsabor67
 
elsabor67's Avatar

Name: elsabor67
Title: Senior Member
Status: Offline
Join Date: Oct 2006
Location: Germany ('Till 2010)
Rate My Car: 35 / 340
Your Ride: 1989 325i (U.S. Specs)
I am still troubleshooting mine because it does the same identical thing. If I figure it out before you do, I will let you know what I did to resolve it. If you get it before I do, could you pass me a PM and let me know what you did? Good luck.
__________________

How do I spell relief??
AUTOBAHNNNNNNNNN
"GO FASTER !!"
  Reply With Quote
Old 09-01-2007, 03:34 PM   #6
John L. Harrell

Name: John L. Harrell
Title: United Newb
Status: Offline
Join Date: Aug 2007
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 87 325i
I guess you have not resolved the idle problem?
A few things to check.
Is the compressor clutch engaging and is there a load, charged a/c system?
Is the throttle switch working/ properly adjusted?
What ECU is installed. ECU's prior to the 173 run 1.1 firmware which exhibits a jerkiness when the throttle is closed and compressor disengages. Swap ECU's to another of the same series or higher - 351,380,525,526.

Best thing for that Haynes manual is for it to be lost.
Do not dick with the idle mixture set screw or fuel pressure. You will screw up what is right. The ECU will be working overtime to compensate for what you are dicking with.
There is no idle speed adjustment for A/C operation. You are not working on a 68 Chevy!

Happy hunting.
  Reply With Quote
Old 09-08-2007, 01:25 PM   #7
Exilion
 
Exilion's Avatar

Name: Exilion
Title: Senior Member
Status: Offline
Join Date: Oct 2006
Location: World wide
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 1991 325i
Wow sorry guys I must have spaced out for a few months there. Thanks for the info though. It seems alot of people are having this problem now

Oh yeah about the haynes manual...... I got a bentley manual and like I'm majoring in marine systems engineering. Hopefully I won't have many problems in the future.

Last edited by Exilion; 09-08-2007 at 01:26 PM..
  Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
528I gear problem, Please help me guys, plz plz djfactor E12, E28, E34, E39, E60 3 10-22-2006 06:56 PM
Need a little A/C help E36Bimmer E36 11 06-18-2006 03:44 PM
A/C Problem -Aux fan stops Siaren Z Series (Z3, Z4, Z8) 11 05-17-2006 11:03 AM
Might have a problem with my dealer nick_318is E21, E30 6 04-05-2006 03:30 PM
Angel Eye Problem, one halo not working right Tochenzo E36 7 12-07-2005 07:46 PM


All times are GMT -5. The time now is 05:30 AM.

A vBSkinworks Design

 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright © 2005-2013 UnitedBimmer.com