Go Back   United Bimmer Community - BMW Forum > UnitedBimmer- Model Categories > 5-Series > E12, E28, E34, E39, E60
FAQ Members List Calendar Advertise With Us Mark Forums Read

E12, E28, E34, E39, E60 General discussion and technical help for all year 5 series cars.

Reply
 
Thread Tools
Old 09-11-2013, 11:26 AM   #1
Birdogs7

Name: Birdogs7
Title: United Newb
Status: Offline
Join Date: Sep 2011
Location: Florida
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 2001 740IL, 1999 528iT
MAF sensor...my findings

The MAF sensor on my 1999 528iT went bad recently, and so I ordered one of the "cheap" ones off eBay. I should have done my homework...Those "cheap" units from China are real junk. From the start my little 6 Cly. "chugged" a bit before coming up to idle. I did reset the OBD BTW with my Peake scanner after the initial install.

After a couple of weeks of giving the new unit a try, I kicked down the transmission to try and get in front of a 18 wheeler via the on ramp on I-75. "Bang" went the rear end, and the "Tranny" light kicked on.

After completing the "25-30 sec." re-set, and resetting the OBD with my Peake scanner, all was well; as long as I did not shift down to accelerate.

I did try something too. I disconnected the MAF sensor cable, and the "Tranny" light came on...After the reset, I installed a better grade/re-manufactured MAF, and the problems seem to have gone away.

I have followed several threads on this and other BMW blogs regarding MAF issues, and wished to chime in with my experience. Bottom line, the MAF sensor sends signals to the Engine AND Transmission computers...If the MAF is bad, even a little, it will affect the two.

Roundel Regards
  Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
maf sensor fishgetter1 E21, E30 1 06-19-2012 02:29 PM
maf sensor fishgetter1 E21, E30 4 05-28-2012 09:51 PM
maf code p0101 bigxcam E36 2 08-15-2009 11:51 PM
can i adjust MAF settings? or clean MAF element falak sher E36 4 02-12-2009 10:34 PM
MAF sensor cleaner works then doesn't. gldfshkpr E36 15 02-10-2008 04:53 PM


All times are GMT -5. The time now is 03:59 AM.

A vBSkinworks Design

 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright © 2005-2013 UnitedBimmer.com