Go Back   United Bimmer Community - BMW Forum > UnitedBimmer- Model Categories > E46
FAQ Members List Calendar Advertise With Us Mark Forums Read

E46 General discussion and technical help for 1999-2004 3 series cars.

Reply
 
Thread Tools
Old 11-16-2010, 07:10 AM   #1
emartin12

Name: emartin12
Title: United Newb
Status: Offline
Join Date: Jun 2010
Location: Indianapolis
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 2002 3251
Rough Idle During Cold Start

I have a 2002 325i that runs great but has an unusual rough idle only on cold starts. When I start the car in the morning, it idles higher and I hear the secondary air pump working, but when it starts to idle lower the engine shudders for a few seconds and then smooths out. There are no codes being thrown and the engine performs great in every other aspect. Is this normal? Is this just because the secondary air pump is injecting air into the system. Just curious if this is normal.
  Reply With Quote
Old 11-17-2010, 06:13 AM   #2
salimos

Name: salimos
Title: United Newb
Status: Offline
Join Date: Oct 2010
Location: Lebanon
Rate My Car: 321 / 340
Your Ride: 2001 BMW 325i
Hey,
I had a similar problem and it turned out it was a vacuum leak, check this link to my post
http://www.unitedbimmer.com/forums/e...fications.html

If you let the care idling more than 5 min on cold start does you RPM start to jump or gos below 500?

Regards,
__________________
SaLiMoS
  Reply With Quote
Old 11-18-2010, 09:09 AM   #3
Manolito

Name: Manolito
Title: Member
Status: Offline
Join Date: May 2006
Location: Sacramento
Rate My Car: 338 / 340
Your Ride: (2) '97 328s; '04 330; '04 325iT
Vacuum leak is a good suspect. Vacuum leaks that are tough to find and are most noticeable during warmup can be at the intake manifold gasket.

I have problems with rough cold idle on three of my four high mileage 3-series cars. They appear to be combinations of several small problems. Two repairs that I did this year that helped, but did not eliminate the rough cold idle were:
1) Replaced the cam position sensor on one of my '97s
2) Replaced the secondary air pump check valve on the other '97.

Who knows, if I do each of these repairs to the 'other' car, perhaps I will completely correct the cold rough idle on the e36s.
  Reply With Quote
Old 11-18-2010, 09:15 AM   #4
emartin12

Name: emartin12
Title: United Newb
Status: Offline
Join Date: Jun 2010
Location: Indianapolis
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 2002 3251
Quote:
Originally Posted by Manolito View Post
Vacuum leak is a good suspect. Vacuum leaks that are tough to find and are most noticeable during warmup can be at the intake manifold gasket.

I have problems with rough cold idle on three of my four high mileage 3-series cars. They appear to be combinations of several small problems. Two repairs that I did this year that helped, but did not eliminate the rough cold idle were:
1) Replaced the cam position sensor on one of my '97s
2) Replaced the secondary air pump check valve on the other '97.

Who knows, if I do each of these repairs to the 'other' car, perhaps I will completely correct the cold rough idle on the e36s.
What has me confused is that it throws no codes and competely levels out after a rough idle of only 4 to 5 seconds as it idles down from startup.
  Reply With Quote
Old 11-20-2010, 11:35 PM   #5
Manolito

Name: Manolito
Title: Member
Status: Offline
Join Date: May 2006
Location: Sacramento
Rate My Car: 338 / 340
Your Ride: (2) '97 328s; '04 330; '04 325iT
There are very few codes that an OBC can set before it it warm and running closed loop. Rough idle in the first couple of minutes of operation will not result in any codes unless the problem continues while the car is warm.

My wife's 330 started having rough startup around 75,000 miles. Hers sounds like it may have a leaking injector that drips when the car is off. I have not tracked down the problem yet, but she is not complaining so it has not made my priority list.

Last edited by Manolito; 11-20-2010 at 11:39 PM..
  Reply With Quote
Old 04-28-2011, 01:04 PM   #6
charlie1

Name: charlie1
Title: United Newb
Status: Offline
Join Date: Apr 2011
Location: falkirk
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 1999 bmw 318i e46
had similar problem with 318i ,check air intake hoses are not leaking or cracked and breather hose from the head
  Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP, 94 530, once warm no power, low rough idle, sounds wierd under acceleration Darknezz E12, E28, E34, E39, E60 2 09-16-2010 08:38 AM
Cold start only idle fine after getting it started bigxcam E36 6 07-31-2009 08:16 AM
Need diagnosing help on 99 M3 E36, Rough Idle, Cold Start Issues kazamali E36 7 04-23-2009 09:29 AM
01' 325i rough idle fmbmw E46 4 10-17-2008 08:50 PM
Cold idle vs Running idle Jami318is E21, E30 3 06-27-2007 01:56 PM


All times are GMT -5. The time now is 07:08 PM.

A vBSkinworks Design

 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright © 2005-2013 UnitedBimmer.com