Go Back   United Bimmer Community - BMW Forum > UnitedBimmer- Model Categories > M3
FAQ Members List Calendar Advertise With Us Mark Forums Read

M3 General discussion and technical help all year M3 cars.

Reply
 
Thread Tools
Old 09-03-2010, 03:04 PM   #1
nycnative

Name: nycnative
Title: United Newb
Status: Offline
Join Date: Sep 2010
Location: nyc
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 2006 m3
Unhappy service engine soon light with codes p0160,p0159,p0304,p0300

i just got my 2006 m3 error codes read and there are engine misfires along with bad o2 sensor. is it possible the o2 sensor os the culprit? the light was on for about 2 months and it ran fine, until today. now it starts find but when i give it gas, it feels like it's dragging an anchor.
  Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Service Engine Soon Light Rustynutt E46 1 06-15-2009 03:47 PM
OK - getting codes, CHECK ENGINE light works, but it's not on! volvodefector79 E36 1 11-13-2007 05:46 PM
Service Engine Soon (OBD II) light donniemac E46 2 05-09-2007 10:12 PM
Service engine soon light Numark318i E46 10 03-21-2007 01:35 PM
Service Engine Soon light reset luispest 7 Series (E23, E32, E38, E65, E66) 4 06-28-2006 09:05 AM


All times are GMT -5. The time now is 03:19 PM.

A vBSkinworks Design

 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright © 2005-2013 UnitedBimmer.com