Go Back   United Bimmer Community - BMW Forum > UnitedBimmer- Model Categories > Z Series (Z3, Z4, Z8)
FAQ Members List Calendar Advertise With Us Mark Forums Read

Z Series (Z3, Z4, Z8) General discussion and technical help for all year Z series cars.

Reply
 
Thread Tools
Old 12-23-2006, 10:47 PM   #1
LJohnson6

Name: LJohnson6
Title: United Newb
Status: Offline
Join Date: Dec 2006
Location: Florida
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 2003 Z4 Roadster
Z4 tracking problem

I own a 2003 Z4 with a 3.0 and sport package with the stock 18 inch wheels. My problem is that it tracks like crazy on any road that is not very smooth. Anyone else have this problem or a solution ?????
Larry
  Reply With Quote
Old 12-24-2006, 06:25 AM   #2
Dudesky

Name: Dudesky
Title: Run Far
Status: Offline
Join Date: Apr 2005
Location: Jersey City, NJ
Rate My Car: 106 / 340
Your Ride: E39 530iA
Maybe this read might help:
http://www.tirerack.com/tires/tirete....jsp?techid=47

Welcome to UB.c
__________________
  Reply With Quote
Old 12-24-2006, 07:28 AM   #3
LJohnson6

Name: LJohnson6
Title: United Newb
Status: Offline
Join Date: Dec 2006
Location: Florida
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 2003 Z4 Roadster
Thanks for the link. I appreciate the help.
Larry
  Reply With Quote
Old 12-24-2006, 11:58 AM   #4
nick_318is
 
nick_318is's Avatar

Name: nick_318is
Title: Suspended License
Status: Offline
Join Date: Jul 2005
Location: Detroit, MI, I Heart E30s
Rate My Car: 10 / 340
Your Ride: 1991 318is (e30 m42), 2007 Mazdaspeed 3
Welcome, I was going to ask if you drive on some well used roads cause I do and ocassionally notice this, its not really something to worry about.

Welcome to ub.c
  Reply With Quote
Old 12-24-2006, 11:38 PM   #5
LJohnson6

Name: LJohnson6
Title: United Newb
Status: Offline
Join Date: Dec 2006
Location: Florida
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 2003 Z4 Roadster
Most are smooth but a lot of two lane stuff. I have had 3 Z3's and another 3.0 Z4 but none had this problem. I was wondering if it was the charactaristics of the 18 inch wheels and sport package?
  Reply With Quote
Old 12-24-2006, 11:49 PM   #6
witeshark
 
witeshark's Avatar

Name: witeshark
Title: Suspended License
Status: Offline
Join Date: Apr 2005
Location: Miami FL
Rate My Car: 84 / 340
Your Ride: 89 325i 5 speed
Quote:
Originally Posted by LJohnson6
Most are smooth but a lot of two lane stuff. I have had 3 Z3's and another 3.0 Z4 but none had this problem. I was wondering if it was the charactaristics of the 18 inch wheels and sport package?
Actually that may be. I had a bro say that about a Firebird with 245-50-16's and nothing was wrong with the car
  Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
A Known Instrument Cluster Problem KickingKing E36 6 11-16-2011 09:50 PM
E36 : anyone had this problem? akinthecat E36 6 09-28-2007 05:35 PM
528I gear problem, Please help me guys, plz plz djfactor E12, E28, E34, E39, E60 3 10-22-2006 06:56 PM
Might have a problem with my dealer nick_318is E21, E30 6 04-05-2006 03:30 PM
Angel Eye Problem, one halo not working right Tochenzo E36 7 12-07-2005 07:46 PM


All times are GMT -5. The time now is 04:33 AM.

A vBSkinworks Design

 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright © 2005-2013 UnitedBimmer.com