Go Back   United Bimmer Community - BMW Forum > UnitedBimmer- Model Categories > Z Series (Z3, Z4, Z8)
FAQ Members List Calendar Advertise With Us Mark Forums Read

Z Series (Z3, Z4, Z8) General discussion and technical help for all year Z series cars.

Reply
 
Thread Tools
Old 09-06-2006, 10:52 PM   #1
MarcS

Name: MarcS
Title: United Newb
Status: Offline
Join Date: Sep 2006
Location: Sausalito, CA
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 2001 Z3 2.5i
Trunk/boot problem with 2001 Z3 2.5i

Hey everyone,

Been browsing the site a while, but finally registered. Hoping someone can help me out.

The trunk latch for my Z has always been a little stubbron, frequently having to push down pretty hard to get it to latch. Well, this weekend, with the boot pretty much full to the gills, a piece of fabric got stuck over the latch, and I tried to shut it a few times, with normal amount of force, to try and get it closed, before I realized what was blocking it. Unfortunately, after rearranging and making sure nothing was sticking up or otherwise blocking, it won't latch at all. Period.

So far I have:
- Remove the mechanism covers to just visually inspect that everything looks in working order. It does.
- adjusted the position of the metal hook piece attached to the car, in case it had been pushed down.
- Adjusted the position of the latching mechanism in case it was off.
- Done some checks to make sure the latching mechanism is pushing down on the metal "hook" at the right point. It seems to be, but I have no way of telling for sure without setting up a really overly intricate setup involving a webcam inside the boot to verify that it is closing on the right spot.

Anyone who can help, or might have had a similar problem, or anything, it would be greatly appreciated. I can take pictures, provide any more helpful details, just.. I feel like this must have a pretty easy way to fix it, but so far, coming up empty.

Cheers!

MarcS
  Reply With Quote
Old 09-06-2006, 11:17 PM   #2
xsperf
 
xsperf's Avatar

Name: xsperf
Title: United Baller
Status: Offline
Join Date: Apr 2005
Location: Syracuse, NY
Rate My Car: 185 / 340
Your Ride: 95 325is
you may want to check if it can move freely, im just speaking in general, with these latches, there is usually a little bar, or something, that is pushed away when the trunk comes to close and then it comes back again, powered by a spring, to stop the trunk from opening again, i dont know if you get what i mean, but if you do, make sure that that piece can move freely and doesnt stay open
__________________

Quote:
Originally Posted by c1apton
I keep forgetting that - I have a great memory but it doesn't last long

CRS disease = Can't Remeber Shit
  Reply With Quote
Old 09-06-2006, 11:18 PM   #3
witeshark
 
witeshark's Avatar

Name: witeshark
Title: Suspended License
Status: Offline
Join Date: Apr 2005
Location: Miami FL
Rate My Car: 84 / 340
Your Ride: 89 325i 5 speed
My first shot would be some light oil, maybe WD40
  Reply With Quote
Old 09-07-2006, 12:52 AM   #4
MarcS

Name: MarcS
Title: United Newb
Status: Offline
Join Date: Sep 2006
Location: Sausalito, CA
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 2001 Z3 2.5i
Oil.. there's a thought. I'm kind of embarassed I haven't tried that yet.

The mechanism itself appears to be working ok. If I manually push up on the latching mechanism, it does close and lock, and pressing the trunk release button does indeed release it. Just the motion of pushing it down doesn't seem to work. I'll try oiling or wd-40ing it in the morning and then go from there. I have an appointment scheduled, but it's not till the end of the month, and I'm not keen on leaving it like this for a whole month.

Thanks for the help so far, and I'll update if I figure it out prior to having "trained professionals"(tm) fix it for me.

Cheers, and goodnight!

MarcS
  Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Z3 steering problem - help! dale Z Series (Z3, Z4, Z8) 10 01-18-2012 11:26 AM


All times are GMT -5. The time now is 03:48 AM.

A vBSkinworks Design

 
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright © 2005-2013 UnitedBimmer.com