View Single Post
Old 07-22-2011, 01:39 PM   #1
acorn2autumn

Name: acorn2autumn
Title: United Newb
Status: Offline
Join Date: Jul 2011
Location: Spokane, WA
User not setup in Rate My Car.
Click here to set it up.
Your Ride: 1994
Gear shift stuck, can't turn key off in my BMW 540I Auto

1994 auto BMW 540I 8cylinder DO-HC.

About 4 months ago, while parking, the gear shift got stuck when shifting from drive to park, locking the key in the ignition. I wasn't on a hill or anything. There wasn't any warning of wear and tear either.

The only gears I can shift to are the forward driving gears (drive, 2 & 3). I can force it barely into neutral, but the shift display shows it flicker between drive and neutral even with shoving the lever forward. Neutral is the option for starting it so it's irritating. Won't let me shift to reverse or park. The shift release button isn't stuck or broke. Nothing happened to cause anything to get bent or broke.

There were no issues with the ignition or steering column before it locked up. Now the key won't turn to the off position or come out of the ignition, no matter how much I jiggle it. The key easily turns to start the car but won't turn to the off position, only to accessory. Engine easily turns over. No problem accepting the mfg lock code, so that isn't the cause.
The only dummy notice on the dash says "check rear brake lights", have read that might be a cause somehow on another forum, but they have good connection. The dummy lights don't report any other issues. The struts are soft but that's the only obvious repair it needs. I've checked all the fluids, hoses, connections and fuses.

I removed the console around the gear shift to check for broken parts, spills, or debris. I didn't see any corrosion or excess dirt anywhere either.

I have tried to fix it by pressing the brake, turning the steering wheel, forcing the gear shift loose, using a fully charged battery, tried to shift past neutral while coasting. I tried to push the break in neutral to see if I could move the pin, seeing if that was the issue, but nothing happened.

When I bought my car it had a bad transmission. I had one installed, now it auto shifts perfectly. Doesn't seem to be an issue with the solenoid, starter, or steering either. Brakes are new and the calipers are working fine.

The engine has plenty of get up and go, sounds great, with no leaks, so its not all falling apart. Nothing "looks" wrong, but their obviously is a jam somewhere.

Please help, I paid a lot for the car and new transmission, tapping my budget! I would really like to avoid taking it to a mechanic, paying $80 just so say hi, if there is something stupidly simple I may have overlooked. Thanks for your help!
  Reply With Quote