View Single Post
Old 08-15-2006, 02:50 AM   #1
devinwwu

Name: devinwwu
Title: Senior Member
Status: Offline
Join Date: Apr 2005
Location: Auburn, WA
Rate My Car: 49 / 340
Your Ride: `00 540i6 Alpine White, `96 740iL Aspen Silber
e30 M30 project has BEGUN!!!!

It has begun. i pulled the m30 out of my 91 535i two days ago and i just finished pulling the m20 out of my 1986 325 tonight. I'm waiting for the e30.de mounts in the mail as well as the e28 radiator and some other odds and ends. i should have the motor cleaned up and put in by the end of next week. i have a few questions for those of you who have done this. the mechanical fit doesn't seem too hard to me but the electrical has me somewhat perplexed. in terms of the plugs that are supposed to plug together from the existing e30 m20 plug to the m30 plug which side comes from which section. is it the male from the m30 and female from the e30 chassis or is it the female from the m30 and the male from the e30 chassis.
here are some pics of what i mean if you guys could check out what your setup is i would appreciate it.
which one of these plugs out of the 91 535i chassis (m30) do i need (if any)


this is the plug on the e30 chassis right now... it comes out of the fuse box and it is a female connection.


The problem is that i have the harness that hooks up to the m30 ecu that i am pulling through the firewall but there are only female harnesses coming from the m30 motor so they won't hook up to the current e30 mounts.

any help is greatly appreciated
  Reply With Quote