United Bimmer Community - BMW Forum

United Bimmer Community - BMW Forum (http://www.unitedbimmer.com/forums/index.php)
-   E46 (http://www.unitedbimmer.com/forums/forumdisplay.php?f=6)
-   -   transmission problems (http://www.unitedbimmer.com/forums/showthread.php?t=43844)

charly 04-04-2012 05:49 AM

transmission problems
 
hello everybody,
my name is charly and im new to this forum but im in dire need of help because i have had enough mechanics give me different opinions.
in detail:
when i start my car in the morning it wont shift, i can shift it to D and nothing , R nothing, after struggling with it for a few minutes and trying to accelerate it will give me the ! mark on my dashboard, when i reset the car and struggle for a couple more minutes it eventually shifts into gear and works perfectly all day as if nothing happened!
when checked it gave me the 0720 code output speed sensor circuit, although the mechanics said that the sensor is not the cause of the problem.
Note my car is a 325 ci 2001.
any suggestions?

DEATH2000 04-04-2012 11:21 AM

Well I think your car is in "limp mode", which is designed to protect your engine and transmission during a fault. It very well could e your output speed sensor but this is a big fix. You have to remove the transmission pan and the valve body as the sensor is on top of the valve body. This is very easy to mess up so you should let a mechanic replace it of needed. Sadly it's a dealer only part.

Taken from E46 Fanatics:
Transmission Input and Output Speed Sensors:
The transmission speed sensors (turbine and output shaft) are analog inductive
sensors that produce an AC sine wave similar to an ABS/ASC wheel
speed sensor. The AC signal frequency is proportional to the rotation speed
of the monitored components .
• The turbine speed sensor scans a pulse wheel attached to the forward clutch housing.
• The output shaft speed sensor scans a pulse wheel attached to the rear ring gear.
The GS 20 monitors these signals along with the engine speed signal (CAN) to calculate
transmission slip ratio for plausibility and for the adaptive pressure control function.
The sensors are monitored for plausible signals, opens and shorts. Specific fault codes are
stored for defects with these sensors.

These links are part diagrams showing you where it is located.

http://www.realoem.com/bmw/showparts...93&hg=24&fg=15

http://www.e46fanatics.com/forum/att...4&d=1252429734

charly 04-04-2012 12:54 PM

Thank you for your reply, its much appreciated.
so those who said it was the valve body were wrong. or is the sensor part of the valve body? would it be easier to replace the sensor itself of the valve body all together? i apologies for all the questions but i've been through hell and back these last couple of month i haven't been able to enjoy the car ever since i bought it which was 2 months ago and it's frustrating.

DEATH2000 04-04-2012 01:39 PM

It's okay, I understand your frustration. The speed sensor is underneath the valve body. Doesn't nessecarilly mean that the valve body needs replacement but to get at the speed sensor it will need to be removed. It's common for a sensor to fail over time.

Manolito 04-19-2012 10:53 AM

I think that the other likely suspect is the temperature sensor. If that is generating a signal that is way out of bounds, the transmission won't work. The good news is that the temperature sensor is more accessible, though you still have to pull off the pan.

I am no transmission expert, but my understanding is that a well-equipped shop should be able to plug in to the computer and identify a bad sensor problem very quickly.


All times are GMT -5. The time now is 07:26 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright © 2005-2013 UnitedBimmer.com