United Bimmer Community - BMW Forum

United Bimmer Community - BMW Forum (http://www.unitedbimmer.com/forums/index.php)
-   7 Series (E23, E32, E38, E65, E66) (http://www.unitedbimmer.com/forums/forumdisplay.php?f=11)
-   -   7 Series E38 - audio working/ not working - airbag light flickering... (http://www.unitedbimmer.com/forums/showthread.php?t=26738)

Durny 06-06-2011 06:29 AM

7 Series E38 - audio working/ not working - airbag light flickering...
 
Hi All,
I've got a 1998 E38 (& very nice it is too).
However, yesterday I left the engine off, key in & radio on (for the wife). When I got back in the car the radio had just suddenly stopped.
I started up the car & the airbag light was on and the radio would not turn on, no time was displayed etc - just blank. The computer display worked ok though. The airbag light flickered for a while & then went out - radio came back on.
Next time I started the car the airbag light was on & no radio & no computer display - all blank. The light went off after a bit but still had a dead radio etc.
Just in case it's related I was having trouble with the radio suddenly going distorted & loud now & again (only on FM). If I left it a while then it worked ok again for a while then did it again etc. etc. . Don't know if that's just a radio problem or related to the general gremlins that are now cropping up?
Any advice greatfully received!
Thanks.
Steve


All times are GMT -5. The time now is 08:45 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright © 2005-2013 UnitedBimmer.com