United Bimmer Community - BMW Forum

United Bimmer Community - BMW Forum (http://www.unitedbimmer.com/forums/index.php)
-   E12, E28, E34, E39, E60 (http://www.unitedbimmer.com/forums/forumdisplay.php?f=8)
-   -   Ignition tumbler difficult to turn and doesn't come back to ON position easily (http://www.unitedbimmer.com/forums/showthread.php?t=18495)

Alex 1993 525i auto 08-17-2010 03:55 PM

Ignition tumbler difficult to turn and doesn't come back to ON position easily
 
Ignition tumbler difficult to turn and doesn't come back to ON position easily...

At 1st it is my Indie bmw shop mechanic who noticed that the key wouldnt come back from starter to ON position as it should. I was used to it and didn't care until I noticed that when my wife was using the car the starter was turning forever and the creeping sound of the starter turning added a me few more gray hairs...

My mechanic told me that he've seen quite a few of older E34 with steering lock/interlock that were worned out which caused the ignition barrel not to come back to the on position after start. Eventually when the steering lock broke the car would not start of course.

So I bought the OEM part and replaced it as explained by the nice write-up of David : http://www.bimmerboard.com/forums/posts/566688

Took me 3 attempts to get it done, easier with the proper tools... but I managed to finish the job, install the new steering lock on the column (need to buy a better snap ring tool if I have to do that again...), the car started after without srs light.

But now my original problem is worse and the steering is difficult to get to lock after removing the key and the key is very difficult to turn and the key is more difficult to get back to the on position after the car is started.

My question is then did I do something wrong, should I have soaked the steering column hole (where the lock engage) with grease?

The new steering lock had grease in the mechanism, as my old one (but the old one grease was brown of course). Looking at my old steering lock nothing look broken, neither on the ignition barrell as well.

Is it the ignition switch spring which is too old/soft to push the mechanism/ignition barrell back to the ON position after starting the car, or something's wrong with my ignition barrel?

Sorry for the long post but I wanted to give all the details to make it clear for anyone who went through similar job, that could help me fix that for good.

Thanks!

525i 1993 (built 05), M50TU, auto, 230k miles

Big Evil 08-19-2010 10:52 AM

Possibly an alignment issue with the install making it hang up.


All times are GMT -5. The time now is 05:48 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright © 2005-2013 UnitedBimmer.com