United Bimmer Community - BMW Forum

United Bimmer Community - BMW Forum (http://www.unitedbimmer.com/forums/index.php)
-   M3 (http://www.unitedbimmer.com/forums/forumdisplay.php?f=7)
-   -   01 m3 code help! (http://www.unitedbimmer.com/forums/showthread.php?t=17802)

bimmergreg 04-18-2010 11:09 PM

01 m3 code help!
 
Hey i have a 2001 bmw m3 woth 76000 miles, recently my service engine soon light came on. the codes i was seeing were;

P0304 (cylinder 4 misfire)
P0305 (cylinder 5 misfire)
P0306 (cylinder 6 misfire)
P0300 (multiple misfire detected)
P1585 (misfire with empty tank)
P0174 (system too lean on bank 2)
P0157 (O2 Sensor circuit low voltage (bank 2 sensor 2))


I have been reding through some other forums and someone had most of all of those codes right after they had cleaned their MAFS. They ended up getting a new MAFS and the codes didnt show up again. So i though maybe it was my MAFS and decided to take it out a clean it with MAF sensor cleaner. I then waited for it to dry than put it back in and cleared all the codes to see if it helped.
I then drove it for a while and got 1 more code within the next days.

P0175 (System to rich bank 2)


Does anyone know what i should do?! what do people usually do when they have this problem? Is there a sensor or something that usually goes out around 75000 miles? Does this happen often?

M3RACR 04-28-2010 10:48 AM

Did all of the codes come up again + the P0175? Or just the P0175? I suspect they all came back...

bimmergreg 04-28-2010 03:21 PM

Quote:

Originally Posted by M3RACR (Post 172420)
Did all of the codes come up again + the P0175? Or just the P0175? I suspect they all came back...

No just the p0175 does very soon after i clear the codes. but now i've driven it for about a week or 2 and i checked codes again.

than i got
P0174 - system to lean bank 2
P0154 - O2 sensor circuit no activity detected (bank 2 sensor 1)
P0157 - O2 sensor circuit low voltage (bank 2 sensor 2)

right after the codes are reset. within 5 to 10 minutes of driving p0174 - system to lean bank 2 comes right back on.

M3RACR 04-28-2010 04:04 PM

if I were you I would change the O2 sensors, since they are giving you erratic fault codes. It's expensive, but if they have never been changed, it's time.

bimmergreg 04-29-2010 06:21 PM

alright sounds good thats what im thinking because i have been drivin around for a few weeks than checked the codes again and got..

P0174 - system to lean bank 2
P0154 - O2 sensor circuit no activity detected (bank 2 sensor 1)
P0157 - O2 sensor circuit low voltage (bank 2 sensor 2)

right after the codes are reset. within 5 to 10 minutes of driving p0174 - system to lean bank 2 comes right back on.

im wondering if you think i should replace both bank 2 sensors? and if so do you guys would know which ones they are so that i will know which sensors are bad. Because im not sure how they do the bank 1 and 2?
for 02 sensors there is 4 it says... (even though i've only seen 2 of them)
front manifold - before and after cadalytic converter
rear manifold - before and after cadalytic converter

do those refer to as the first 3 cylinders = front manifold?
and 4,5, and 6 = rear manifold?
thanks!


All times are GMT -5. The time now is 03:55 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright © 2005-2013 UnitedBimmer.com